Ticket #494 (closed defect: fixed)

Opened 4 years ago

Last modified 2 years ago

Connecting to the network after an offline kerberos auth logs continuous error messages to sssd_ldap.log

Reported by: sgallagh Owned by: sgallagh
Priority: blocker Milestone: SSSD 1.2.1
Component: LDAP Provider Version: 1.1.91
Keywords: Cc:
Blocked By: Blocking:
Tests Updated: no Coverity Bug:
Patch Submitted: Red Hat Bugzilla: 591873
Design link:
Feature Milestone:
Design review: Fedora test page:
Chosen: Candidate to push out:
Release Notes:

Description (last modified by sgallagh) (diff)

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=591873

Description of problem

Connecting to the network after an offline auth logs continuous error messages to sssd_ldap.log which causes it to grow at a rapid pace until stopping it by doing a "service sssd restart".

Version-Release number of selected component (if applicable)

sssd-1.1.91-10.el6.x86_64

How reproducible

Every time

Steps to Reproduce

  • Do a tail -f /var/log/sssd/sssd_ldap.log on a separate terminal for

monitoring.

  1. configure sssd.conf for kerberos auth.
  2. login as "sssd" user to cache credentials - authentication successful.
  3. logout.
  4. disconnect the network.
  5. login as "sssd" - authentication successful with cached credentials.
  6. logout.
  7. connect the network.
  8. wait for a few seconds ~30.
  9. Observer the log messages in the other terminal.

Actual results

<snip>
(Thu May 13 15:11:38 2010) [sssd[be[ldap]]] [sdap_process_result] (8): Trace:
sh[0x1bc0e20], connected[0], ops[(nil)], ldap[0x1bc1040]
(Thu May 13 15:11:38 2010) [sssd[be[ldap]]] [sdap_process_result] (2): ERROR:
LDAP connection is not connected!
(Thu May 13 15:11:38 2010) [sssd[be[ldap]]] [sdap_process_result] (8): Trace:
sh[0x1bc0e20], connected[0], ops[(nil)], ldap[0x1bc1040]
(Thu May 13 15:11:38 2010) [sssd[be[ldap]]] [sdap_process_result] (2): ERROR:
LDAP connection is not connected!
(Thu May 13 15:11:38 2010) [sssd[be[ldap]]] [sdap_process_result] (8): Trace:
sh[0x1bc0e20], connected[0], ops[(nil)], ldap[0x1bc1040]
(Thu May 13 15:11:38 2010) [sssd[be[ldap]]] [sdap_process_result] (2): ERROR:
LDAP connection is not connected!
</snip>

The above error gets logged continuously until a service sssd restart.

Expected results

Should not log any error messages.

Additional info

Configuration: https://bugzilla.redhat.com/attachment.cgi?id=413728

Full log: https://bugzilla.redhat.com/attachment.cgi?id=413731

Change History

comment:1 Changed 4 years ago by sgallagh

  • Description modified (diff)

comment:2 Changed 4 years ago by sgallagh

  • Status changed from new to assigned

comment:3 Changed 4 years ago by sgallagh

  • fixedin set to 1.2.1
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 Changed 2 years ago by mkosek

  • Red Hat Bugzilla set to [https://bugzilla.redhat.com/show_bug.cgi?id=591873 591873]
Note: See TracTickets for help on using tickets.