Ticket #35 (closed defect: worksforme)

Opened 6 years ago

Last modified 4 years ago

[sssd[nss]] [nss_cmd_getpwuid_callback] (0): No matching domain found for [4999], fail!

Reported by: jlaska Owned by: jhrozek
Priority: major Milestone: SSSD 1.0
Component: SSSD Version: 0.3.3
Keywords: Cc:
Blocked By: Blocking:
Sensitive: Tests Updated:
Coverity Bug: Patch Submitted:
Red Hat Bugzilla: 0 Design link:
Feature Milestone:
Design review: Fedora test page:
Chosen: Candidate to push out:
Release Notes:
Temp mark:

Description

While testing https://fedorahosted.org/sssd/wiki/Fedora_11_Test_Day/PAM_Local_Native using sssd-0.3.3-3.fc11.x86_64, and executing step#5 to create a local user, I get the following error:

# useradd validlocaluser -u 4999
[sssd[nss]] [nss_cmd_getpwuid_callback] (0): No matching domain found for [4999], fail!
[sssd[nss]] [nss_cmd_getgrgid_callback] (0): No matching domain found for [4999], fail!

Also interesting, after observing the above message I:

  1. attempt to useradd again, this fails as expected
  2. attempt to userdel, this passed as expected
  3. attempt to useradd, this fails ... unexpected
# useradd validlocaluser -u 4999
useradd: user validlocaluser exists

# userdel -r validlocaluser

# useradd validlocaluser -u 4999
useradd: user validlocaluser exists

# getent passwd validlocaluser
validlocaluser:x:4999:4999::/home/validlocaluser:/bin/bash

Change History

comment:1 Changed 6 years ago by sgallagh

  • Owner changed from somebody to jhrozek

Jakub, would you mind having a look at this?

comment:2 Changed 6 years ago by sgallagh

  • Resolution set to worksforme
  • Status changed from new to closed
  • fixedin set to 0.4.0

Unable to reproduce. We believe this was fixed incidentally during other NSS work.

comment:3 Changed 4 years ago by dpal

  • Red Hat Bugzilla set to 0
Note: See TracTickets for help on using tickets.