Ticket #1509 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

libsss_sudo is not updated when yum update sssd is called

Reported by: jhrozek Owned by: jhrozek
Priority: major Milestone: SSSD 1.9.0 RC1
Component: SSSD Version:
Keywords: Cc:
Blocked By: Blocking:
Sensitive: Tests Updated: no
Coverity Bug: Patch Submitted: yes
Red Hat Bugzilla: 834593 Design link:
Feature Milestone:
Design review: Fedora test page:
Chosen: Candidate to push out:
Release Notes:
Temp mark:


https://bugzilla.redhat.com/show_bug.cgi?id=834593 (Fedora)

It seems like libsss_sudo does not have a versioned dependency on sssd, so when
sssd is updated libsss_sudo is not.
We should probably have a sepcific version dependency unless we consider the
sss-sudo protocol stable and ABI change safe to run sssd and libsss_sudo built
from different versions.

Change History

comment:1 Changed 3 years ago by jhrozek

  • Status changed from new to assigned
  • tests set to 0
  • Owner changed from somebody to jhrozek
  • Tests Updated unset
  • upgrade set to 0

comment:2 Changed 3 years ago by jhrozek

  • Patch Submitted set

comment:3 Changed 3 years ago by dpal

  • Milestone changed from NEEDS_TRIAGE to SSSD 1.9.0 RC1

comment:4 Changed 3 years ago by jhrozek

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.