Ticket #1496 (closed defect: duplicate)

Opened 20 months ago

Last modified 20 months ago

[abrt] sssd-1.8.4-14.fc17: ldap_pvt_sasl_getmechs: Process /usr/libexec/sssd/sssd_be was killed by signal 11 (SIGSEGV)

Reported by: jhrozek Owned by: somebody
Priority: major Milestone: SSSD 1.9.0 RC1
Component: SSSD Version:
Keywords: Cc:
Blocked By: Blocking:
Tests Updated: no Coverity Bug:
Patch Submitted: no Red Hat Bugzilla: 850717
Design link:
Feature Milestone:
Design review: Fedora test page:
Chosen: Candidate to push out:
Release Notes:

Description

https://bugzilla.redhat.com/show_bug.cgi?id=850717 (Fedora)

libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/libexec/sssd/sssd_be --domain eladian.com --debug-to-files
comment:        Found in ABRT.
crash_function: ldap_pvt_sasl_getmechs
executable:     /usr/libexec/sssd/sssd_be
kernel:         3.3.4-5.fc17.x86_64
pid:            12031
pwd:            /
remote_result:  NOTFOUND
time:           Mon 06 Aug 2012 09:04:14 AM EDT
uid:            0
username:       root

backtrace:      Text file, 11957 bytes
dso_list:       Text file, 5797 bytes
maps:           Text file, 27803 bytes

build_ids:
:d897c6286d20d2db78676afa9e61a1e81cf0ea98
:664ed02205756e404bd2c47242bfa068fe47d85d
:20ad9f242a6a13d40812f9254ab3f7a9cd7cb9e0
:8568e11bef79abaf14513d18a8559282d8dad34a
:5cb52239c901fea9e4e3ba272e477c145de9fd04
:d20b830074550e82ac5b1d826a560e409f22aade
:b6d75088f555d197be1476cb1c580640826ae029
:dec0de92024bee74c75c04bde4c54c097fe68ae8
:7d61742840a7789720054cc9eeccceb5d18eb584
:f1c5764c91642a33bec2d4ba5adbefc196cc8d60
:07d2432f2cea31e902ec19ecdc72dde8df873864
:fad2d57f73db1d2b51917a93ac42fb4e1308b141
:88426ee2dde057368a4d4787e70fdeb65ff479cc
:75bf7346adf5ee83b722adb882e21a0319becbb1
:4b187979e8f98a4d120569a6b7a9675a97d3311e
:1f50755ef5d8fab74f327e92db73655c75ae81bc
:024d4d1edd51e68072a465694b1a51cbaa563da4
:e1899330a605d544f3d8bedf6b05bc1f8aba9b63
:fb23e8dfe3b5bb920649d7c89f5cbf9b4b90236d
:a1cc14da7d74178bb1811a32e465e562592ce4f5
:f4f9ce91c43285df84177f9684a3e7f190a0aae1
:c2f5ae8bd64df0fc996cf96b95525a8f8fb28fd2
:1e94a86f40c5316ab6d90680569d98215fbfb193
:09d06ad35875b6c1cc1228c1db4cd87febe279c3
:30864b32b1bc65fdc5f1ed14540ed355be042b13
:f64b7319b84d426ed547084bdb2577f4f596c18f
:cd6934c7ffdc10b4626f8a94336de83eb989545e
:e5430d3cfd0dc81a60b3658b2044eb21520bdae2
:bbd97d5fe9e66203b5a45614f34ccaa74f53d919
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65
:350920b52e92655cdb258fa5f96fe7004ad07a52
:e6612de9b0cd29052e8f8154cb5b387385022a74
:67792c148d2b8f13f6732c9367e926c26d7376c5
:74e80262cc6aa0592980c3e7c744c3c0458126ea
:3d60535f052babb998bae4807bc992c5d15df5c4
:602ff13e97125737c96d96a5cfb2a40eaab428bf
:c028bd4d4e5f5ae122f2300193d9a08f103da6f7
:73777e822e00ca152ffca281ab0ace0cb498ec48
:13718b5000238cc2421cc0ad9d3ba8a6e6bf8a00
:8f1c8e7a9290087a1de608de917e41455f885af0
:47a7ca7ab63f870dafbf93efcd706787cc7550b8
:d32cbeacfd9f41e3cd29b697dd111f44a2d9c127
:3a0d8731ddfc2de9d8a19ac284d429977c919d77
:78f0ce899315c3aa026a117260f485d413835cc7
:8032681acfadb3c8b9e0a6e74cd58d8c36363450
:a00974e147dbc921a938ab4406f362a6f239832d
:f45c8eb8882261e50418b38ac09ca8a0ec6caba2
:9e4bf25e4bd9f22607a4ff926bc0b62d9d8fd47d
:6e2537ccbd5fafa7671f182cbd0b30c46c59bd49
:731b3801f71de6bd888953161b715e6cbda0ab60
:d804f8ee47797da9213a92f00cd095ecada8d79f
:da9d286837f87c41da9c304b59f03b784bf264de
:09a429c265e226db4b6b72f88db428daf0bccf30
:10db86ab9481dc0e2bd0f0c4c987e86a8a1d9a8b
:38420ca51d326b65b172427ed6bf58b41a40f53c
:aaa1236e690a9d2f230ade4b8d4387c22200ba9f
:5dd234206476b0387cd251598aa72a2c95c763c5
:822e9b3523e8312240f41a25722d539bc77ed436
:dca47ea6bba2080d40648e37afb401fc89c9dbaa
:46eb8c83b266e03b4d2d37c5ac56accdee78c113
:1b7abd5c8129b91c0ca4f0f0812e61660236fd38
:0ca4c0cae2bdb7169f65cee25a37f86becb42f02
:2d920fc18d5d62c399484534249b104e12049777
:dea4920aaab787b26f0b664406f216eb8c9a6e09
:79aee4375d1f48c032b56a6a0a9c15b3773b030e

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/system/sssd.service
:2:cpuset:/
:1:name=systemd:/system/sssd.service

core_backtrace:
:74e80262cc6aa0592980c3e7c744c3c0458126ea 0x19a3b ldap_sasl_interactive_bind
libldap-2.4.so.2 -
:74e80262cc6aa0592980c3e7c744c3c0458126ea 0x19cba ldap_sasl_interactive_bind_s
libldap-2.4.so.2 -
:1e94a86f40c5316ab6d90680569d98215fbfb193 0x8c80e sdap_auth_send libsss_ipa.so
-
:1e94a86f40c5316ab6d90680569d98215fbfb193 0x8d419 - libsss_ipa.so -
:1e94a86f40c5316ab6d90680569d98215fbfb193 0x8dca5 - libsss_ipa.so -
:1e94a86f40c5316ab6d90680569d98215fbfb193 0x86d3e - libsss_ipa.so -
:fb23e8dfe3b5bb920649d7c89f5cbf9b4b90236d 0x49d7e - [pie] -
:09d06ad35875b6c1cc1228c1db4cd87febe279c3 0x6b2a - libtevent.so.0 -
:09d06ad35875b6c1cc1228c1db4cd87febe279c3 0x3cb0 _tevent_loop_once
libtevent.so.0 -
:09d06ad35875b6c1cc1228c1db4cd87febe279c3 0x3e3b tevent_common_loop_wait
libtevent.so.0 -
:fb23e8dfe3b5bb920649d7c89f5cbf9b4b90236d 0x46d43 server_loop [pie] -
:fb23e8dfe3b5bb920649d7c89f5cbf9b4b90236d 0xc359 main [pie] -

environ:
:SYSFONT=True
:PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
:PWD=/
:LANG=en_US.UTF-8
:KEYTABLE=us
:SHLVL=0
:BOOT_IMAGE=/vmlinuz-3.3.4-5.fc17.x86_64
:_SSS_LOOPS=NO
:KRB5RCACHEDIR=/var/cache/krb5rcache

limits:
:Limit                     Soft Limit           Hard Limit           Units
:Max cpu time              unlimited            unlimited            seconds
:Max file size             unlimited            unlimited            bytes
:Max data size             unlimited            unlimited            bytes
:Max stack size            8388608              unlimited            bytes
:Max core file size        0                    unlimited            bytes
:Max resident set          unlimited            unlimited            bytes
:Max processes             773282               773282               processes
:Max open files            1024                 4096                 files
:Max locked memory         65536                65536                bytes
:Max address space         unlimited            unlimited            bytes
:Max file locks            unlimited            unlimited            locks
:Max pending signals       773282               773282               signals
:Max msgqueue size         819200               819200               bytes
:Max nice priority         0                    0
:Max realtime priority     0                    0
:Max realtime timeout      unlimited            unlimited            us

open_fds:
:0:/dev/null
:pos:   0
:flags: 0100002
:1:/dev/null
:pos:   0
:flags: 0100002
:2:/dev/null
:pos:   0
:flags: 0100002
:3:/var/log/sssd/sssd.log
:pos:   109
:flags: 0102001
:4:anon_inode:[eventpoll]
:pos:   0
:flags: 02000002
:5:pipe:[53927900]
:pos:   0
:flags: 04000
:6:pipe:[53927900]
:pos:   0
:flags: 04001
:7:pipe:[53927896]
:pos:   0
:flags: 04000
:8:pipe:[53927896]
:pos:   0
:flags: 04001
:9:anon_inode:[eventpoll]
:pos:   0
:flags: 02000002
:10:anon_inode:inotify
:pos:   0
:flags: 04000
:11:/var/lib/sss/db/config.ldb
:pos:   168
:flags: 02100002
:12:socket:[53927899]
:pos:   0
:flags: 04002
:13:/var/log/sssd/sssd_eladian.com.log
:pos:   84069
:flags: 0102001
:14:anon_inode:[eventpoll]
:pos:   0
:flags: 02000002
:15:/var/lib/sss/db/cache_eladian.com.ldb
:pos:   168
:flags: 02100002
:16:socket:[53927902]
:pos:   0
:flags: 02004002
:17:socket:[53927903]
:pos:   0
:flags: 02004002
:18:/var/log/sssd/ldap_child.log
:pos:   0
:flags: 0102001
:19:/var/log/sssd/krb5_child.log
:pos:   0
:flags: 0102001
:20:socket:[53941870]
:pos:   0
:flags: 02004002
:21:socket:[53941875]
:pos:   0
:flags: 02004002
:22:socket:[53941876]
:pos:   0
:flags: 02004002
:23:socket:[53941877]
:pos:   0
:flags: 02004002

var_log_messages:
:Aug  5 13:00:25 devtradedb1-nyc1 sssd_be: GSSAPI Error: Unspecified GSS
failure.  Minor code may provide more information (Cannot contact any KDC for
realm 'ELADIAN.COM')
:Aug  6 09:04:14 devtradedb1-nyc1 kernel: [1727578.130351] sssd_be[12031]:
segfault at 0 ip 00007f16d47d3a3b sp 00007fff5ac6c880 error 4 in
libldap-2.4.so.2.8.3[7f16d47ba000+4c000]
:Aug  6 09:04:14 devtradedb1-nyc1 abrt[30448]: Saved core dump of pid 12031
(/usr/libexec/sssd/sssd_be) to /var/spool/abrt/ccpp-2012-08-06-09:04:14-12031
(35655680 bytes)

Change History

comment:1 Changed 20 months ago by dpal

  • upgrade set to 0
  • Tests Updated unset
  • Status changed from new to closed
  • tests set to 0
  • Milestone changed from NEEDS_TRIAGE to SSSD 1.9.0 RC1
  • Resolution set to duplicate

Duplicate of #1364

Note: See TracTickets for help on using tickets.