Ticket #1245 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

"Error looking up public keys" while ssh to replica using IP address.

Reported by: sgallagh Owned by: jcholast
Priority: blocker Milestone: SSSD 1.8.2 (LTM)
Component: SSH Keys Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:
Tests Updated: no Coverity Bug:
Patch Submitted: no Red Hat Bugzilla: 801719
Design link:
Feature Milestone:
Design review: Fedora test page:
Chosen: Candidate to push out:
Release Notes:

Description

https://bugzilla.redhat.com/show_bug.cgi?id=801719 (Red Hat Enterprise Linux 6)

+++ This bug was initially created as a clone of Bug #801410 +++

Description of problem:


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install ipa-server with dns
2. Install ipa-server replica

3. [root@primenova ~]# ipa dnsrecord-find example.com goldbug
  Record name: @
  NS record: primenova.example.com., goldbug.example.com.
...
  Record name: goldbug
  A record: 10.65.201.101
  SSHFP record: 1 1 A7E007E7EFF842656F17C0A12BEDAD7522C04C1B, 2 1
BED1634D80799DEFDE344DAFDDDF8B56E0EB75E5
-----------------------------
Number of entries returned 10
-----------------------------

4. [root@primenova ~]# ssh goldbug.example.com
root@goldbug.example.com's password:

5. [root@primenova ~]# ssh 10.65.201.101


Actual results:
Error looking up public keys
root@10.65.201.101's password:

Expected results:
Reverse SSHFP lookup should be successful and "Error looking up public keys"
should not be displayed.

Additional info:


--- Additional comment from mkosek@redhat.com on 2012-03-09 04:20:41 EST ---

This check is for SSSD, I wil clone the BZ to this component. I can leave this
BZ as a tracker for IPA.

Change History

comment:1 Changed 2 years ago by jcholast

  • upgrade set to 0
  • Status changed from new to assigned
  • Tests Updated unset
  • Owner changed from somebody to jcholast
  • tests set to 0

comment:2 Changed 2 years ago by sgallagh

  • Priority changed from major to blocker
  • Milestone changed from NEEDS_TRIAGE to SSSD 1.8.2 (LTM)

comment:3 Changed 2 years ago by sgallagh

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:4 Changed 2 years ago by dpal

  • Status changed from closed to reopened
  • Priority changed from blocker to major
  • Milestone changed from SSSD 1.8.2 (LTM) to NEEDS_TRIAGE
  • Resolution fixed deleted

See freeipa ticket https://fedorahosted.org/freeipa/ticket/2657

The issue is still there. Reopening.

comment:5 Changed 2 years ago by sgallagh

  • Status changed from reopened to closed
  • Priority changed from major to blocker
  • Milestone changed from NEEDS_TRIAGE to SSSD 1.8.2 (LTM)
  • Resolution set to fixed

Re-closing. The issue reported there is new and completely different from this ticket. It just coincidentally prints the same error message.

Note: See TracTickets for help on using tickets.