Ticket #1224 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

--debug option for sss_debuglevel doesn't work.

Reported by: sgallagh Owned by: pbrezina
Priority: trivial Milestone: SSSD 1.8.1 (LTM)
Component: sss_tools Version: 1.8.0
Keywords: Cc:
Blocked By: Blocking:
Tests Updated: no Coverity Bug:
Patch Submitted: yes Red Hat Bugzilla: 799039, 799031
Design link:
Feature Milestone:
Design review: Fedora test page:
Chosen: Candidate to push out:
Release Notes:

Description

https://bugzilla.redhat.com/show_bug.cgi?id=799039 (Red Hat Enterprise Linux 6)

+++ This bug was initially created as a clone of Bug #799031 +++

Description of problem:
The Debug level for sss_debuglevel cannot be set with the option --debug

Version-Release number of selected component (if applicable):
[root@fedora-client sss_tools]# rpm -q sssd
sssd-1.8.1-0.20120228T2018Zgit751b121.fc16.i686



How reproducible: Always


Steps to Reproduce:
1. Run sss_debuglevel --debug=1
2. sss_debuglevel --debug=0x0020


Actual results:
[root@fedora-client sss_tools]# sss_debuglevel --debug=1
Usage: sss_debuglevel [-?] [-?|--help] [--usage] [--debug=INT] [-c|--config
STRING] DEBUG_LEVEL_TO_SET
Specify debug level you want to set
[root@fedora-client sss_tools]# sss_debuglevel --debug=0x0020
Usage: sss_debuglevel [-?] [-?|--help] [--usage] [--debug=INT] [-c|--config
STRING] DEBUG_LEVEL_TO_SET
Specify debug level you want to set


Expected results:
The Debug Level should be set accordingly

Additional info:

Change History

comment:1 Changed 2 years ago by sgallagh

  • Red Hat Bugzilla changed from [https://bugzilla.redhat.com/show_bug.cgi?id=799039 799039] to [https://bugzilla.redhat.com/show_bug.cgi?id=799039 799039], [https://bugzilla.redhat.com/show_bug.cgi?id=799031 799031]

comment:2 Changed 2 years ago by sgallagh

  • Patch Submitted unset
  • Tests Updated unset
  • upgrade set to 0
  • tests set to 0

comment:3 follow-up: ↓ 4 Changed 2 years ago by pbrezina

It is not a bug but misunderstanding. The --debug option specifies what level should apply to sss_debuglevel.

The level we want to set is a free parameter without an option name.

The proper usage is:

  • sss_debuglevel 1
  • sss_debuglevel 0x0020

An to enable all debug message in the tool and set 0x0020 in sssd:

  • sss_debuglevel --debug 0xfff0 0x0020
Last edited 2 years ago by pbrezina (previous) (diff)

comment:4 in reply to: ↑ 3 Changed 2 years ago by sgallagh

  • Owner changed from somebody to pbrezina

Replying to pbrezina:

It is not a bug but misunderstanding. The --debug option specifies what level should apply to sss_debuglevel.

Neither the --help nor manpage suggests this. I wasn't aware that's how it worked either (and it's inconsistent with our other tools, which have --debug as a hidden option using POPT_ARGFLAG_DOC_HIDDEN.

Please hide the option from the --help

comment:5 Changed 2 years ago by sgallagh

  • Patch Submitted set
  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 2 years ago by sgallagh

  • Milestone changed from NEEDS_TRIAGE to SSSD 1.8.1 (LTM)
Note: See TracTickets for help on using tickets.