Ticket #843 (closed task: fixed)

Opened 6 years ago

Last modified 5 years ago

Draft Fedora 11 Schedule

Reported by: poelstra Owned by: poelstra
Milestone: Fedora 10 Final Component: other
Keywords: Cc: jkeating
Blocked By: Blocking:

Description (last modified by jkeating) (diff)

In response to mail thread started by Paul Frields we need to draft a schedule for Fedora 11.

I'll take ownership of this task and target having something ready by the week of 2008-10-13.

Change History

comment:1 Changed 5 years ago by anonymous

  • Owner changed from poelstra@… to anonymous
  • Status changed from new to assigned

Here is a proposed schedule for Fedora 11: http://poelstra.fedorapeople.org/schedules/f-11/f-11-all-milestones.html http://poelstra.fedorapeople.org/schedules/f-11/f-11-all-tasks.html

Here are some of the thoughts behind it: 1) To try and finish Fedora 11 and make a it a good by May 1, 2009 will be extremely challenging given the setbacks with Fedora 10 (delayed approximately one month), scheduling of FUDCon F11, and upcoming USA/Red Hat employee holiday schedule (almost two work weeks). 2) Make sure we have a full six month release schedule that compensates for holidays when people are away (Thansksgiving and "Winter Break") 3) Add two extra freezes before beta to solidify features and key components that have impacted previous releses 4) Propose a shorter schedule for Fedora 12 to get back on "May Day/Halloween?" release schedule

--target a Fedora 12 release at the End of October/first part of November 2009. --consider Fedora 12 a "quality" release?

Overall I think this is the best schedule scenario with the most potential for a predictable and solid Fedora 11 release.

Jesse has suggested adding the length of each freeze to the schedule. I'll try get those added to one of the next schedule revisions.

comment:2 Changed 5 years ago by poelstra

  • Owner changed from anonymous to poelstra
  • Status changed from assigned to new

comment:3 Changed 5 years ago by poelstra

  • Status changed from new to assigned

sorry I wasn't logged in when I made the previous (horribly formatted) comment

comment:4 follow-up: ↓ 7 Changed 5 years ago by poelstra

I've received some private concerns about the schedule link posted yesterday. I thought I was making it easier by proposing the best option, but I suppose that is a matter of opinion depending on what folks believe the key driver for a Fedora release should be and what our constraints are. I believe our constraints are: schedule, quality, and content. In most successful projects you can only set two hard constraints and must be flexible with the third.. otherwise things usually don't go so well.

Here are a few more possibilities. Naturally we can consider others too with other inputs and desired outcomes.

For a combined view: http://poelstra.fedorapeople.org/schedules/f-11/f-11-combined-scenarios.html

Here are some things I thought were important and considered while putting together the two July 2009 scenarios:

  • analysed the actual schedule results for past four releases (F7 to F10): development, freezes, testing time, etc.
  • built F11 schedule prototypes using average (what I thought were realistic) task durations based on the prior release schedules
  • factored in RHT holidays and shutdowns into schedule calculations whereby tasks are extended to receive specified duration in "work" days not "calendar" days: in other words if it usually takes us a certain number of days to do something, history has shown we usually don't end up getting it done sooner even if we say we will from the start.

comment:5 Changed 5 years ago by kkofler

"4) Propose a shorter schedule for Fedora 12 to get back on "May Day/Halloween?" release schedule" -> I don't think that's doable with that F11 schedule, it would leave only 3 months for F12, and that's not even factoring in slippage for F11.

comment:6 Changed 5 years ago by katzj

Not trying to be attacking, but for a schedule outside of the "plan" of May/October? I don't think that rel-eng should be the group making the decision.

The plan of record is that we do releases May Day and Halloween. Making the schedule should just be to hit those targets (possibly with some slight allowance for the fact that we're a month late for F10, but not three months worth of allowance). For more fundamental changes to the schedule, there should be a much more transparent discussion with the board and/or fesco on a more appropriate list such as f-a-b or fedora-devel.

comment:7 in reply to: ↑ 4 Changed 5 years ago by katzj

Replying to poelstra:

  • analysed the actual schedule results for past four releases (F7 to F10): development, freezes, testing time, etc.

The problem is our actuals don't match the plan. Even when we adjust the plan to take into account prior actuals :)

  • factored in RHT holidays and shutdowns into schedule calculations whereby tasks are extended to receive specified duration in "work" days not "calendar" days: in other words if it usually takes us a certain number of days to do something, history has shown we usually don't end up getting it done sooner even if we say we will from the start.

Holidays are a factor every calendar year. If we try to take them into account, then we can't have regular six month releases as things will drift later and later each year by taking them into account.

comment:8 Changed 5 years ago by pfrields

I think the ticket says "Draft," not "Decide." :-) John has put together kind of a "kitchen-sink" schedule that tries to meet everyone's needs (maybe somewhat unreasonably, but with a true aim). It would make sense to look at that draft and figure out what falls out based on our priorities for Fedora. Those results then inform a discussion about the actual F11 schedule.

Not coincidentally, those priorities might help us determine whether some of our processes and mechanisms in Fedora are working the way we want -- e.g. Rawhide, length of test phases, etc.

comment:9 Changed 5 years ago by jkeating

This ticket is to get releng to agree on a recommended schedule to pass off to FESCo, board, et al for further discussion

comment:10 Changed 5 years ago by jkeating

  • Description modified (diff)
  • Cc jkeating added

I discovered a problem with our schedules. Given that Preview release is a full fledged on the mirrors type release (man we have too many of those) I need more time between the final freeze and when Preview is to be made available. A week just doesn't cut it.

comment:11 Changed 5 years ago by jkeating

  • Description modified (diff)

(Gah, I typed more stuff into the wrong box)

Something more like the time between Beta freeze and Beta public avail is more suitable.

Of course, we could discuss the merit of doing a full fledged mirror release of Preview, just shortly before the Final release. I think I'd be much happier turning Preview release into just another snapshot release type only on torrents.

comment:12 Changed 5 years ago by poelstra

Schedule change log:

Let me know if we want to reduce the amount of detail and if so where

comment:13 Changed 5 years ago by jkeating

  • Milestone changed from Fedora 10 Preview to Fedora 10 Final

This has spawned a larger conversation about what to do with F11/F12 and that is going to FESCo tomorrow. I'm dropping this off the Preview milestone and moving it to the Final milestone.

comment:15 Changed 5 years ago by jkeating

My only concern is the tail end of the schedule, where we have preview release coming out on April 28th, and starting the release candidates on the 12th of May, and only having 9 days to get a perfect tree for a release on the 26th. This last release (10) has shown that we can miss things if we rush the end. As such, I think the stuff we create on the 12th is truly the release candidate, pre-staged and everything. That makes the "compose stage sync" date of the 21st less true, as that date now becomes more of a "If it's not staged to the master mirror by now, we slip the release". Not quite sure how to word that.

I'd create a "compose & stage" entry that starts on the 12th and runs to the 21st. Create a "sync" date on the 21st which is when we'd release it to mirrors after we've evaluated the final product in it's entirety. The 21st would also become our stop-ship date, either we ship, or we slip.

comment:16 Changed 5 years ago by jkeating

  • Status changed from assigned to closed
  • Resolution set to fixed

This was adjusted and approved by FESCo

Note: See TracTickets for help on using tickets.