Ticket #5349 (closed task: fixed)

Opened 19 months ago

Last modified 17 months ago

Create Fedora 18 Beta test compose (TC) and release candidate (RC)

Reported by: adamwill Owned by: rel-eng@…
Milestone: Fedora 18 Beta Component: koji
Keywords: Cc: wutao85, robatino, jsmith, athmane, jdulaney, thedonvaughn, tflink, rbergero, kparal, pschindl, nirik, jreznik
Blocked By: Blocking:

Description

It's time to start doing Fedora 18 Beta composes:

http://jreznik.fedorapeople.org/schedules/f-18/f-18-releng-tasks.html

"Create Beta Test Compose (TC) - Tue 2012-10-02"

So let's have a TC1! Please use https://admin.fedoraproject.org/updates/livecd-tools-18.12-1.fc18 to build the live images, it should make them EFI bootable (this has been broken for a few days). Please use https://admin.fedoraproject.org/updates/FEDORA-2012-14395/lorax-18.20-1.fc18 to build the DVDs, we usually want to use the latest lorax. Also, we have some stuff that should be pulled in to the composes:

The Deliverables SOP is still in draft status, but it may be useful as a reference: ​https://fedoraproject.org/wiki/User:Adamwill/Draft_releng_SOP_deliverables . For Beta we need netinst, DVD, and lives for four main desktops plus SoaS.

Change History

comment:1 Changed 19 months ago by ausil

  • Status changed from new to closed
  • Resolution set to fixed

comment:2 Changed 19 months ago by adamwill

Re-opening for TC2. We need to fix https://bugzilla.redhat.com/show_bug.cgi?id=862537 , the issue which prevented TC1 from booting without modifications to the kernel parameters - I believe that's a compose issue? Please advise if it's not.

Aside from that, we need:

That's all, but it's a significant change (big changes to partitioning).

comment:3 Changed 19 months ago by ausil

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:4 Changed 19 months ago by ausil

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:6 Changed 19 months ago by ausil

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:7 Changed 19 months ago by adamwill

Re-opening for TC4. In addition to the above, please pull:

I don't have anything else on the list. Thanks!

comment:9 Changed 19 months ago by kevin

  • Status changed from closed to reopened
  • Resolution fixed deleted

Lives were made without the correct version of livecd-tools.

Re-spinning them now.

comment:10 Changed 19 months ago by kevin

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:11 Changed 18 months ago by tflink

  • Status changed from closed to reopened
  • Resolution fixed deleted

Re-opening for TC5. In addition to what's in stable, please pull in:

Please make sure that the build environment is using the latest lorax:

comment:12 Changed 18 months ago by kevin

Compose fails with:

yum.Errors.YumRPMCheckError: [u'ERROR with transaction check vs depsolve:', 'pykickstart >= 1.99.20 is needed by anaconda-18.18-1.fc18.i686', u'Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum']

so, ok to add pykickstart-1.99.20.fc18 ?

comment:13 follow-up: ↓ 14 Changed 18 months ago by kevin

Sorry, thats pykickstart-1.99.20-1.fc18.

comment:14 in reply to: ↑ 13 Changed 18 months ago by tflink

Replying to kevin:

Sorry, thats pykickstart-1.99.20-1.fc18.

Yeah, I forgot that was a requirement of newer anaconda. Please add pykickstart-1.99.20-1.fc18 as a dependency of anaconda.

comment:15 Changed 18 months ago by kevin

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:16 Changed 18 months ago by adamwill

  • Status changed from closed to reopened
  • Resolution fixed deleted

Re-opening for TC6 (I know it's quick) with:

We haven't tested the new anaconda yet, but hey, if it turns out to be DOA, we can just work on TC5 instead. This way we have two builds.

comment:17 Changed 18 months ago by robatino

From TC5 i386 DVD (will file bug):

package: epiphany-extensions-3.5.0-0.2.20120914gitf4fcbfc.fc18.i686 from myrepo

unresolved deps:

epiphany(abi) = 0:3.5

comment:18 Changed 18 months ago by kevin

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:20 in reply to: ↑ 19 Changed 18 months ago by kparal

Replying to adamwill:

I believe this has currently broken dependencies, pykickstart >= 1.99.21 has to be added to the update.

comment:21 Changed 18 months ago by kevin

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:22 Changed 18 months ago by adamwill

Hold that thought - https://bugzilla.redhat.com/show_bug.cgi?id=872446 is a bad enough regression that we shouldn't build a TC with it included. Wait for anaconda 18.24 before doing TC7. I'll update the request later.

comment:23 Changed 18 months ago by adamwill

OK, looks like we're ready to fire TC7 now. Request is exactly as in comment #19, with these changes:

pykickstart was pushed stable separately, so kparal's note doesn't apply.

comment:25 Changed 18 months ago by ausil

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:27 Changed 18 months ago by kevin

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:28 Changed 18 months ago by adamwill

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:29 Changed 18 months ago by ausil

http://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC9/

some of the live cd tasks failed weirdly im digging into why and will put the missing lives up when complete.

comment:30 Changed 17 months ago by ausil

  • Status changed from reopened to closed
  • Resolution set to fixed

all done

comment:31 follow-up: ↓ 32 Changed 17 months ago by adamwill

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:32 in reply to: ↑ 31 Changed 17 months ago by tflink

Replying to adamwill:

This is not needed for upgrades with fedup, just fedup-dracut (and fedup-dracut-plymouth which is a subpackage of fedup-dracut and part of the same update) for F18.

Also, upgrades need the new systemd:

comment:33 Changed 17 months ago by ausil

  • Status changed from reopened to closed
  • Resolution set to fixed
Added x86_64 repo from /srv/pungi/18-Beta-RC1/18-Beta/Fedora/x86_64/os
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   x86_64
Num Packages in Repos: 4172

Added i386 repo from /srv/pungi/18-Beta-RC1/18-Beta/Fedora/i386/os
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   i386
Num Packages in Repos: 4178

http://dl.fedoraproject.org/pub/alt/stage/18-Beta-RC1/

Note: See TracTickets for help on using tickets.