Ticket #4982 (closed task: invalid)

Opened 2 years ago

Last modified 2 years ago

Boost Upgrade to 1.48.0

Reported by: denisarnaud Owned by: rel-eng@…
Milestone: Component: koji
Keywords: Boost, rawhide, upgrade, rebuild Cc: pmachata, bkoz, tomspur
Blocked By: Blocking:

Description

The Boost package has been upgraded to version 1.48.0. Koji has successfully built it for Fedora Rawhide.

The following list of packages need to be rebuilt:

akonadi
aqsis
aqsis-core
aqsis-libs
asc
avogadro
avogadro-libs
barry
bastet
cclive
cegui-python
CGAL
collada-dom
compiz
compiz-fusion-extras
compiz-fusion-unsupported
compiz-gtk
compiz-kde
compiz-plugins-main
easystroke
ekiga
ember
esteid-browser-plugin
fatrat
fawkes-plugin-player
fife
flush
fusecompress
fuse-encfs
gearmand
glob2
glom
glom-libs
gnash
gnash-cygnal
gnash-klash
gnuradio
gpsdrive
guitarix
HippoDraw-python
hugin
hugin-base
iwhd
k3d
kalzium
kalzium-libs
kig
libcompizconfig
libmapi
libmongodb
libopenvrml
libopenvrml-gl
libpst-python
LuxRender
LuxRender-core
LuxRender-devel
LuxRender-lib
lyx
mapnik
mapnik-python
mapnik-utils
mbox2eml
minion
mkvtoolnix
mkvtoolnix-gui
mmseq
mongodb
mongodb-server
mygui
mygui-demos
mygui-devel
mygui-tools
nss-gui
ogre
ogre-samples
ompl
OpenImageIO
openvrml-java
openvrml-javascript
openvrml-nodes
openvrml-xembed
pdns
perl-qpid
pingus
player
plee-the-bear
pokerth
pyactivemq
pyexiv2
pymilia
python-gnash
python-polybori
python-tag
python-visual
qbittorrent
qbittorrent-nox
qpid-cpp-client
qpid-cpp-client-devel
qpid-cpp-client-rdma
qpid-cpp-client-ssl
qpid-cpp-server
qpid-cpp-server-cluster
qpid-cpp-server-rdma
qpid-cpp-server-ssl
qpid-cpp-server-store
qpid-cpp-server-xml
qpid-qmf
QuantLib-test
rb_libtorrent
rb_libtorrent-examples
rb_libtorrent-python
rcsslogplayer
rcssmonitor
rcssserver
ruby-qpid-qmf
schroot
simspark
source-highlight
spring
springlobby
swift
tncfhh-examples
tncfhh-libs
twinkle
undertaker
vegastrike
vigra-python
votca-csg
votca-csg-libs
votca-tools
wesnoth
wesnoth-server
wesnoth-tools
wlmproxy
xsd
zarafa-server

Note: I shall take care of my own packages, at least, i.e, airrac, airsched, rmol, simfqt, stdair and travelccm.

Change History

comment:1 Changed 2 years ago by ausil

  • Status changed from new to closed
  • Resolution set to invalid

sorry this is not something releng does, you need to coordinate it by notifing the devel list of the soname bump. https://fedoraproject.org/wiki/PackageMaintainers/Packaging_Tricks#When_breaking_Application_binary_interface

comment:2 Changed 2 years ago by denisarnaud

Ok, I understand. Indeed, most of the packages have been rebuilt already. Only a few are still FTBFS, apparently due to some "bug fixes" (and/or regressions) in Boost-1.48. Any way, thanks for having had a look at it.

Note: See TracTickets for help on using tickets.