Ticket #3860 (closed task: fixed)

Opened 4 years ago

Last modified 4 years ago

Create Alpha Release Candidate (RC): INstall CD/DVD

Reported by: jkeating Owned by: rel-eng@…
Milestone: Fedora 14 Alpha Component: other
Keywords: release-task Cc: jlaska, rhe, robatino, poelstra, newgle1
Blocked By: Blocking:

Description

Missing SOP

Change History

comment:1 Changed 4 years ago by rhe

  • Cc jlaska, rhe, robatino added

comment:2 Changed 4 years ago by jlaska

I believe we are able to initiate a release candidate compose as there are no longer un-MODIFIED F14Alpha blockers on the list.

At the time of this post, the F14Alpha list contains the following issues with updates in updates-testing pending. Please make sure that the packages containing these fixes are included in the compose.

  • 583731 [MODIFIED] man-pages-de has file conflicts with man-db
  • 617115 [ON_QA] rawhide live spins showing black screen instead of syslinux boot menu
  • 619889 [MODIFIED] X.org pegged at 100% CPU usage after booting with systemd
  • 620900 [MODIFIED] traceback on install of F14 Alpha Test Compose #2
  • 620949 [ON_QA] [abrt] gnome-panel-2.31.4-3.fc14: Process /usr/bin/gnome-panel was killed by signal 11 (SIGSEGV)
  • 621298 [MODIFIED] Looks like python2.7 is breaking python-bugzilla package.
  • 621308 [MODIFIED] name of Alpha TC ISOs doesn't have the word "Alpha" in it anymore

There is one remaining un-MODIFIED bug that keeps bouncing (596985). Discussion continues in the bug, Adam Williamson has reached out to Jerome to help narrow down the impact of this issue. In the meantime, we do need a compose to continue making progress on the test matrix. We discussed and concluded that starting the RC will allow further testing, hit our RC milestone.

comment:3 follow-up: ↓ 4 Changed 4 years ago by jlaska

FYI ... the anaconda-devel gang is building a new anaconda that will need to be included as well.

comment:4 in reply to: ↑ 3 Changed 4 years ago by jlaska

Replying to jlaska:

FYI ... the anaconda-devel gang is building a new anaconda that will need to be included as well.

https://admin.fedoraproject.org/updates/anaconda-14.15-1.fc14

comment:5 Changed 4 years ago by poelstra

  • Cc poelstra added

comment:6 Changed 4 years ago by rhe

  • Cc newgle1 added

comment:8 in reply to: ↑ 7 Changed 4 years ago by rhe

Replying to ausil:

http://alt.fedoraproject.org/pub/alt/stage/14-Alpha.RC1/

Thanks.

Two main issues during installation:

  1. Kernel panic occurs in anaconda stage1 of x86_64 images(https://bugzilla.redhat.com/show_bug.cgi?id=621775).
  1. Fail to install from DVD/CD package repo.(https://bugzilla.redhat.com/show_bug.cgi?id=621102)

comment:9 in reply to: ↑ 7 Changed 4 years ago by jlaska

Replying to ausil:

http://alt.fedoraproject.org/pub/alt/stage/14-Alpha.RC1/

Rats! A remaining package dependency/conflict was not linked into the tracking bug. In addition to the issues listed above, bug#620211 (python-psyco) will need to be resolved as well.

comment:10 follow-up: ↓ 11 Changed 4 years ago by jlaska

Please also include the latest systemd in the next compose (see bug#621200 and http://admin.fedoraproject.org/updates/systemd-6-1.fc14).

comment:11 in reply to: ↑ 10 Changed 4 years ago by poelstra

Replying to jlaska:

Please also include the latest systemd in the next compose (see bug#621200 and http://admin.fedoraproject.org/updates/systemd-6-1.fc14).

In addition please make sure the new compose includes fixes for the following bugs discussed at today's blocker meeting http://bit.ly/a41qui:

comment:12 Changed 4 years ago by adamwill

we're likely to need systemd 6-2, there's a significant bug in 6-1 which has heretofore been hidden by the fact that systemd wasn't actually being used in new installs (upstart was).

we also need the compose to use a recently-committed change to comps (listing systemd-sysvinit instead of just systemd) which should solve that problem - making systemd the default rather than upstart.

for 620211, I've submitted an update - https://admin.fedoraproject.org/updates/eclipse-pydev-1.5.9-2.fc14 - for eclipse-pydev, which drops the dep on python-psyco , which should resolve the issue as far as composes are concerned, so we need to push that update and use it in the compose.

comment:13 Changed 4 years ago by adamwill

we will also need this build of dbus:

http://koji.fedoraproject.org/koji/buildinfo?buildID=188125

it was included in the systemd 5-2 update request, but not the 6-1 or 6-2 update requests.

comment:14 follow-up: ↓ 15 Changed 4 years ago by ausil

  • Resolution set to fixed
  • Status changed from new to closed

comment:15 in reply to: ↑ 14 ; follow-up: ↓ 16 Changed 4 years ago by rhe

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to ausil:

http://alt.fedoraproject.org/pub/alt/stage/14-Alpha.RC2/

Thanks.

F14-Alpha-RC2 still used systemd-5-2, therefore caused default.target (and other links) not to be created in the postinstall scriptlets when SELinux is enabled.(https://bugzilla.redhat.com/show_bug.cgi?id=621200)

comment:16 in reply to: ↑ 15 Changed 4 years ago by rhe

Replying to rhe:

Replying to ausil:

http://alt.fedoraproject.org/pub/alt/stage/14-Alpha.RC2/

Thanks.

F14-Alpha-RC2 still used systemd-5-2, therefore caused default.target (and other links) not to be created in the postinstall scriptlets when SELinux is enabled.(https://bugzilla.redhat.com/show_bug.cgi?id=621200)

Oops, systemd-5-2 was installed when using branched repo. DVDs contain 6-2 version. Sorry about that.

But this blocker bug was reproduced: Bug 622058 - fails to run firstboot on first boot of an installed system.

comment:17 Changed 4 years ago by poelstra

In order to finish the Alpha we need to complete the following:

  1. These updates for Alpha-critical bugs that need to be pushed to make the repos sync with RC2 (and make sure we don't forget anything for RC3):
  1. We are waiting on a fix https://bugzilla.redhat.com/show_bug.cgi?id=622058 and then we would like RC3 to be created as soon as possible. We are working against having all of our testing completed by the time of the "Go/No?-Go" meeting on 2010-08-11.

comment:18 Changed 4 years ago by adamwill

looks good. Just a reminder that we specifically do *not* want to cherrypick the newer glib2 and gnome-terminal builds we used in rc2, we simply want to use what's in dist-f14 for those packages.

622058 is tricky; any contributions to figuring out how to fix it would be most welcome. i'm out for a few hours now but will be back bashing on it soon.

comment:20 Changed 4 years ago by adamwill

The firstboot update is up:

https://admin.fedoraproject.org/updates/firstboot-1.112-1.fc14

this specific build is yet untested, as it's slightly different from my personal test build (all the changes had to be moved into an official build with new changelog etc). So I'm rolling another live image to double-check that it works right. But it ought to be fine.

comment:21 follow-up: ↓ 22 Changed 4 years ago by adamwill

one further thing: just to confirm that we need live images to be created as part of the compose, not just DVD/CD/boot.iso, we need the full set of live images also. I think Jesse usually builds DVD/CD/boot.iso and syncs those, then does the live images after that.

comment:22 in reply to: ↑ 21 Changed 4 years ago by jlaska

Replying to adamwill:

one further thing: just to confirm that we need live images to be created as part of the compose, not just DVD/CD/boot.iso, we need the full set of live images also. I think Jesse usually builds DVD/CD/boot.iso and syncs those, then does the live images after that.

FYI, creation of live images is tracked in ticket#3861

comment:23 Changed 4 years ago by ausil

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:24 Changed 4 years ago by adamwill

  • Resolution fixed deleted
  • Status changed from closed to reopened

go/no-go meeting decided to slip, so re-opening for rc4 compose.

proposed task list for rc4:

  • spin-kickstarts change to fix xdriver= for live (I am planning to verify the problem and test a fix for this tonight)

we aim to compose RC4 tomorrow, 2010/08/12.

comment:25 Changed 4 years ago by adamwill

comment:26 Changed 4 years ago by adamwill

If you can, also use this spin-kickstarts commit:

http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=commit;h=c977a972ff5b0c27361ab414bd320960a5afecd6

it fixes background on the LXDE spin.

comment:28 Changed 4 years ago by ausil

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:29 Changed 4 years ago by maxamillion

  • Resolution fixed deleted
  • Status changed from closed to reopened

As a result of the QA meeting today (8/16/2010) we would like to request a Fedora 14 Alpha-RC5 image to be composed in order to include the fix for the following bug in the Alpha release:

https://bugzilla.redhat.com/show_bug.cgi?id=596985

Requesting RC5 compose ASAP.

Many thanks, -AdamM

comment:30 Changed 4 years ago by adamwill

  • Resolution set to fixed
  • Status changed from reopened to closed

in fact, after further consideration, we decided 596985 did not merit blocker status, and hence at this time we do not expect an rc5 will be needed.

Note: See TracTickets for help on using tickets.