Ticket #2547 (closed task: fixed)

Opened 5 years ago

Last modified 4 years ago

Tag request e2fsprogs-1.41.9-5.fc12 for dist-f12-updates-candidate

Reported by: sandeen Owned by: rel-eng@…
Milestone: Fedora 12 Final Component: koji
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by jkeating) (diff)

For 522969 -  ext3 superblock in future
For users in certain timezones and/or with hardware clocks ticking
local time, they encounter full-blown fscks on bootup when fsck
discovers that superblock timestamps are significantly different
from the current time.  This is a regression from F11.

The patch in question just renames an existing config variable,
"buggy_init_scripts" to "accept_time_fudge" and defaults it to "1"
to allow up to 24h of time difference w/o forcing a full fsck.
Ubuntu has used the "buggy_init_scripts" for several releases
now.  The rest of the patch is comment & doc updates.

Change History

comment:1 Changed 5 years ago by notting

  • Milestone set to Fedora 12 Final

comment:2 Changed 5 years ago by notting

I couldn't reproduce the bug, but the new e2fsprogs works for me in the same situation (no forced fsck). +1

comment:3 Changed 5 years ago by jkeating

  • Resolution set to fixed
  • Description modified (diff)
  • Status changed from new to closed

Tagged

comment:4 Changed 4 years ago by adamwill

  • Resolution fixed deleted
  • Status changed from closed to reopened

<Oxf13> I thought I tagged it, somehow it didn't get tagged?

comment:5 Changed 4 years ago by jkeating

  • Resolution set to fixed
  • Status changed from reopened to closed

Tagged for good now.

Note: See TracTickets for help on using tickets.