Ticket #24 (closed task: fixed)

Opened 6 years ago

Last modified 5 years ago

spins for Fedora 9

Reported by: sundaram Owned by: jkeating
Milestone: Fedora 9 Final Component: other
Keywords: Cc: kanarip, jwboyer, kevin
Blocked By: Blocking:

Description

We need custom spins created for Fedora 9. The ks files are now maintained in the spins-kickstart git repository at

https://fedorahosted.org/spin-kickstarts/

  • Games Live DVD
  • Xfce Live CD
  • Electronics Lab
  • Developer Live DVD

You can ignore the localized ks files. The last couple of spins haven't seen an update recently but should work just the same as in Fedora 8. If rel-eng needs any help with this, let me know.

Change History

comment:1 Changed 6 years ago by kanarip

To be more precise on what we're looking at to be spun:

comment:2 Changed 6 years ago by jkeating

  • Owner changed from jwb to jboyer

comment:3 follow-up: ↓ 5 Changed 6 years ago by notting

As stated before, FEL & Developer aren't being done as of now.

comment:4 Changed 6 years ago by jkeating

  • Owner changed from jboyer to jwboyer

comment:5 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 6 years ago by kanarip

Replying to notting:

As stated before, FEL & Developer aren't being done as of now.

I'm sorry, where has that been stated before?

comment:6 in reply to: ↑ 5 Changed 6 years ago by jwboyer

Replying to kanarip:

Replying to notting:

As stated before, FEL & Developer aren't being done as of now.

I'm sorry, where has that been stated before?

The owner of the FEL spin has actively asked that it not be spun for F9, as it is known to be broken and he has little time to fix it.

The Developer spin has no active owner.

comment:7 follow-up: ↓ 8 Changed 6 years ago by kanarip

The FEL spin is being fixed right now - tnorth is sitting next to me and has committed to maintaining the FEL spin. We'll get together with Chitlesh on Saturday to sort things out. Does that fit the schedule -that is, if we succeed?

comment:8 in reply to: ↑ 7 Changed 6 years ago by jwboyer

Replying to kanarip:

The FEL spin is being fixed right now - tnorth is sitting next to me and has committed to maintaining the FEL spin. We'll get together with Chitlesh on Saturday to sort things out. Does that fit the schedule -that is, if we succeed?

I have no set schedule. There are a couple things that need to happen first at any rate:

1) We (rel-eng) need to verify how much space we have to host F9 spins 2) We need to figure out which spins will be done to fit in that space.

Also, if I'm personally to do the spins it will at least be a couple of weeks before I start. I'm moving next week and will be without internet access for a few days. Someone else from rel-eng might be able to pick this up if it's really urgent.

comment:9 Changed 6 years ago by kanarip

Would you consider / add to the meeting agenda as an item, that images composed by release engineering maybe could be tracked by the Fedora Project tracker (but not seeded), but seeded by third parties?

comment:10 Changed 6 years ago by jkeating

Decision: Once spins SIG bless games, XFCE, and FEL rel-eng will create beta i386/x86_64 versions of these spins from F9 GOLD content to be hosted on spins.fp.o. If necessary specific updates will be allowed for specific spins and sources for those updates will be hosted on torrent as well.

jwb will attend the June 10th Spins SIG meeting for more details.

comment:11 Changed 6 years ago by jwboyer

Here is what needs to be done at the moment:

1) File an RFR from Infrastructure to get i686 and x86_64 F9 virt guests deployed with SELinux set to permissive

2) Grab the XFCE, FEL, and Games kickstart files and run the livecd-creator on them on each guest. Of important note here is to only use the F9 Gold bits and not updates. If updates are used, source ISOs are also required.

3) Upload the resulting ISOs to spins.fp.o

comment:12 Changed 6 years ago by jkeating

  • Status changed from new to assigned
  • Owner changed from jwboyer to jkeating

test3 and test4 have been created, test3 being x86_64 and test4 being i386. I'm getting them setup for spinning images (installing livecd-tools, pulling down the F-9 branch of the spin-kickstarts git repo, making sure selinux is going, etc...)

comment:13 follow-up: ↓ 15 Changed 6 years ago by jkeating

FEL fails, it's looking for knetworkmanager which doesn't exist in F9. I thought these were pre-tested?

comment:14 follow-up: ↓ 16 Changed 6 years ago by jkeating

Games doesn't even exist in the F-9 branch. Can somebody please fill me in on what's going on with the spin-kickstarts git repo?

comment:15 in reply to: ↑ 13 Changed 6 years ago by kanarip

Replying to jkeating:

FEL fails, it's looking for knetworkmanager which doesn't exist in F9. I thought these were pre-tested?

I'm sorry... Although I did not explicitly instruct the maintainers to commit their changes to F-9 as well, I see that knetworkmanager is in the latest kickstart as well. I removed it and slapped the maintainers that this shouldn't happen again as they signed off on their kickstarts and are on the receiving end of bugs.

The new kickstart is at fedora-livecd-electronic-lab.ks

comment:16 in reply to: ↑ 14 Changed 6 years ago by kanarip

Replying to jkeating:

Games doesn't even exist in the F-9 branch. Can somebody please fill me in on what's going on with the spin-kickstarts git repo?

The Games kickstart is at fedora-livedvd-games.ks

comment:17 follow-up: ↓ 20 Changed 6 years ago by jkeating

I've been able to successfully make the Fedora Electronics Lab spin for i686/x86_64. However XFCE still fails with selinux, and the Games spin doesn't have an actual session to log into (no gnome, kde, nor xfce). I'm really starting to question the claim that these were 'tested'.

comment:18 Changed 6 years ago by jwboyer

  • Cc kanarip., jwboyer added; kanarip removed

comment:19 Changed 6 years ago by jwboyer

  • Cc kanarip added; kanarip. removed

comment:20 in reply to: ↑ 17 Changed 6 years ago by kanarip

Replying to jkeating:

I'm really starting to question the claim that these were 'tested'.

So am I... I'm wondering what I can do to force testing.

comment:21 Changed 6 years ago by sundaram

My original ks files, I can assure did work properly for more than one person. However there seems to have been changes made in the repository after that which I haven't done that has adverse effects. For example, the games ks inherits the base ks instead of the desktop ks file like I used to. I will try and dig out my original files.

comment:22 Changed 6 years ago by kevin

The Xfce spin selinux issue seems to be caused by the updated livecd-tools package changing selinux handling. The version that was available at f9-gold time works fine. Several of us tested the Xfce spin pretty heavily around f9 release.

See: https://bugzilla.redhat.com/show_bug.cgi?id=454776

comment:23 Changed 6 years ago by kevin

So, looking at bug 454776, it sounds like we should do these f9 spins with the livecd-tools-017-1.fc9 package in the host.

Can we go ahead and do that?

comment:24 Changed 6 years ago by kevin

  • Cc kevin added

comment:25 Changed 6 years ago by jkeating

The spins have been posted on the torrent site as "beta". If no problems are reported they will be promoted to Final releases.

comment:26 Changed 6 years ago by kevin

Is there a specific timeframe for Beta->final promotion? Perhaps this could be documented in the spins docs if all of them are going to go through a Beta phase.

comment:27 Changed 6 years ago by jkeating

Well, that really depends on the spins themselves. If there has been good (or at least no bad) feedback on them, we should rename them from BETA. Can the spin owners comment on this?

comment:28 Changed 6 years ago by anonymous

No bad feedback and some positive feedback on Xfce spin. Feedback on these spins have always been minimal compared to the number of downloads we get even for previous releases so that is not particularly surprising.

comment:29 Changed 5 years ago by jkeating

  • Status changed from assigned to closed
  • Resolution set to fixed

All Fedora 9 spins have been made non-beta.

Note: See TracTickets for help on using tickets.