Ticket #44 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Use universal newlines when getting output from commands

Reported by: jkeating Owned by: jkeating
Priority: minor Milestone: 0.4.0
Component: pungi.py Version: devel
Keywords: Cc:
Blocked By: Blocking:

Description

the resulting log file contains some strange looking output. Mainly the output of createrepo and mksquashfs from the buildinstall call. AFAIK the problem is caused because these two applications use the '\r' in there outputs. When using the universal_newlines option the log file improves a little bit.

-        p1 = subprocess.Popen(command, cwd=rundir, stdout=output, stderr=error)
+        p1 = subprocess.Popen(command, cwd=rundir, stdout=output, stderr=error, universal_newlines=True)

Change History

comment:1 Changed 10 years ago by jkeating

  • Status changed from new to closed
  • Resolution set to fixed

Committed fix to tip.

Note: See TracTickets for help on using tickets.