Ticket #23 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

fast-user-switch-applet has wrong bg color

Reported by: dgeiger Owned by: mso
Priority: minor Milestone:
Component: gtk-nodoka-engine Version: 0.7 beta 2 (0.6.90.2)
Keywords: Cc:
Blocked By: Blocking:

Description

The bg color of the fast-user-switch-applet is #f1eeee, while the rest of the panel has bg color #ece9e9.

Change History

comment:1 Changed 6 years ago by dgeiger

I added a match line to the gtkrc files for each of the respective Nodoka themes; however, I am not certain that this fixes the actual problem, as this doesn't seem to happen in other theme engines.

comment:2 Changed 6 years ago by mso

  • Status changed from new to assigned

The problem is indeed in the gtkrc file. While panel bg is derived from fedora-default style, the fast-user-switch-applet uses bg set in fedora-menubar and panel menu uses bg set in fedora-panel-menubar. I've already managed to fix this locally for Nodoka-Looks and will upload the fix to git while all themes are fixed.

comment:3 Changed 6 years ago by mso

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in git.

comment:4 Changed 6 years ago by dgeiger

  • Resolution fixed deleted
  • Status changed from closed to reopened

Now, the volume control, network monitor, Tomboy, and trash applets have a background of #ece9e9, and the rest of the panel/panel applets have a background of #f1eeee. As well, some other quirks have appeared, such as that the Show Desktop button and the Date/Time? applet button are run up to the edge of the panel, which I am not certain if is desirable.

comment:5 Changed 6 years ago by mso

  • Status changed from reopened to new

Hm... This shouldn't be happening and for me it is not happening. Wonder where the problem is... Just to be sure, I'll rebuild new rpm from latest git snapshot and add a srpm of it on my fedorapeople page.

comment:6 Changed 6 years ago by mso

OK, it does appear now. The fix to this would be to change the fedora-menubar style to not override bg[NORMAL] and getting rid of the patch, then all should be working fine... Or, we would need to make better matches so that we could effectively have whatever panel bg colour we'd like...

The srpm is here: http://mso.fedorapeople.org/nodoka/gtk-nodoka-engine-0.6.99.1-0.7.git.bea309a.fc8.src.rpm

comment:7 Changed 6 years ago by mso

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.