Ticket #53 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Cannot find root file system

Reported by: anonymous Owned by: lmacken
Priority: critical Milestone: v4.0
Component: liveusb.creator Version: 2.0
Keywords: Cannot find root file system Cc: beland@…
Blocked By: Blocking:

Description

Everything looked ok during install, restarted the PC, get the booting count down and splash screen. Then get:

unable to find root file system

Create symlink /dev/root and then exit this shell to continue the boot sequence

bash-3.2#

er, no idea how to do that, please help, thanks

Change History

comment:1 follow-up: ↓ 3 Changed 6 years ago by anonymous

Add to grub boot options

root=/dev/sdb1

comment:2 follow-up: ↓ 4 Changed 6 years ago by lmacken

  • Status changed from new to assigned

Interesting. What does the syslinux/syslinux.cfg on your USB stick look like?

comment:3 in reply to: ↑ 1 Changed 6 years ago by anonymous

Replying to anonymous:

Add to grub boot options

root=/dev/sdb1

Hi, thanks for the quick response, I'm a noob, how exactly do I do that?

comment:4 in reply to: ↑ 2 Changed 6 years ago by anonymous

Replying to lmacken:

Interesting. What does the syslinux/syslinux.cfg on your USB stick look like?

Hi thanks for the quick response, don't have the USB on me right now but how exactly do I do that? Thanks, J

comment:5 Changed 6 years ago by anonymous

Oh some additional information that might be helpful, the USB stick previously had a pendrive linux install on it that worked ok and I formatted the drive in Windows XP using quick format option, hope this is of use, J

comment:6 Changed 6 years ago by anonymous

Ah didn't realise it was just a file I could open with notepad, here it is:

default vesamenu.c32 timeout 100

menu background splash.jpg menu title Welcome to Fedora-9-Live-i686! menu color border 0 #ffffffff #00000000 menu color sel 7 #ffffffff #ff000000 menu color title 0 #ffffffff #00000000 menu color tabmsg 0 #ffffffff #00000000 menu color unsel 0 #ffffffff #00000000 menu color hotsel 0 #ff000000 #ffffffff menu color hotkey 7 #ffffffff #ff000000 menu color timeout_msg 0 #ffffffff #00000000 menu color timeout 0 #ffffffff #00000000 menu color cmdline 0 #ffffffff #00000000 menu hidden menu hiddenrow 5 label linux0

menu label Boot kernel vmlinuz0 append initrd=initrd0.img root=UUID=8C47-C729 rootfstype=vfat rw quiet liveimg overlay=UUID=8C47-C729 rhgb

menu default label check0

menu label Verify and Boot kernel vmlinuz0 append initrd=initrd0.img root=UUID=8C47-C729 rootfstype=vfat rw quiet liveimg overlay=UUID=8C47-C729 rhgb check

label memtest

menu label Memory Test kernel memtest

label local

menu label Boot from local drive localboot 0xffff

comment:7 follow-up: ↓ 8 Changed 6 years ago by lmacken

After you drop to that root prompt, could you try running

/lib/udev/vol_id -u /dev/sdb1

And see what it says? It *should* be 8C47-C729.

comment:8 in reply to: ↑ 7 Changed 6 years ago by anonymous

  • Status changed from assigned to closed
  • Resolution set to fixed
  • Priority changed from major to minor

Replying to lmacken:

After you drop to that root prompt, could you try running

/lib/udev/vol_id -u /dev/sdb1

And see what it says? It *should* be 8C47-C729.

Hi, sorry saw that you had released a new version (2.5) and I tried it before I saw this post. I'm now typing this using Fedora 9 thankyou :). (By the way it was version 2.3 I tried to use before) J

comment:9 Changed 6 years ago by shadow@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi, I'm having similar problem. I downloaded liveusb-creator-2.5 so I guess I should have the latest version. From the discussion above I figured that UUID of the sdb1 must match UUID written in the syslinux.cfg so I modified it and Fedora booted just fine. The problem is that it was unable to mount persistent storage. My LiveOS subfolder looks like:

livecd-iso-to-disk
osmin.img
overlay-FEDORA-68D4-F9FC
squashfs.img

and syslinux.cfg:

default vesamenu.c32
timeout 100

menu background splash.jpg
menu title Welcome to Fedora-9-Live-KDE-i686!
menu color border 0 #ffffffff #00000000
menu color sel 7 #ffffffff #ff000000
menu color title 0 #ffffffff #00000000
menu color tabmsg 0 #ffffffff #00000000
menu color unsel 0 #ffffffff #00000000
menu color hotsel 0 #ff000000 #ffffffff
menu color hotkey 7 #ffffffff #ff000000
menu color timeout_msg 0 #ffffffff #00000000
menu color timeout 0 #ffffffff #00000000
menu color cmdline 0 #ffffffff #00000000
menu hidden
menu hiddenrow 5
label linux0
  menu label Boot
  kernel vmlinuz0
  append initrd=initrd0.img root=UUID=AC56-0E5D rootfstype=vfat rw quiet liveimg overlay=UUID=68D4-F9FC rhgb
menu default
label check0
  menu label Verify and Boot
  kernel vmlinuz0
  append initrd=initrd0.img root=UUID=68D4-F9FC rootfstype=vfat rw quiet liveimg overlay=UUID=68D4-F9FC rhgb check
label memtest
  menu label Memory Test
  kernel memtest
label local
  menu label Boot from local drive
  localboot 0xffff

and during initial boot post I get:

mount: you must specify the filesystem type
umount: /overlayfs: not mounted

Do I have incorrect (or corrupted) overlay file? Or do I have to tell fedora which FS to use an how?

Thanks

comment:10 Changed 6 years ago by anonymous

  • Milestone set to v2.0

comment:11 Changed 6 years ago by bkearney@…

I hit this as well. I am attempting to build a RHEL5 live usb stick. My syslinux.cfg line looked like this:

append initrd=initrd0.img root=UUID=280C-C383 rootfstype=vfat rw quiet liveimg overlay=UUID=280C-C383

I modified it to look like this:

append initrd=initrd0.img root=/dev/sda1 rootfstype=vfat rw quiet liveimg overlay=UUID=280C-C383

And it boots. However, when I save an item to the desktop it is not there on reboot. Is this a RHEL5 thing, or did I edit the file incorrectly?

comment:12 follow-up: ↓ 13 Changed 6 years ago by lmacken

Please try and reproduce this issue with the latest version of the liveusb-creator. Thanks!

comment:13 in reply to: ↑ 12 Changed 6 years ago by shadow@…

Replying to lmacken:

Please try and reproduce this issue with the latest version of the liveusb-creator. Thanks!

I tried v2.7 and everything appears to be working. Good job!

comment:14 Changed 6 years ago by anonymous

I also encountered the same problem,pity for now,I haven't find a solution.My pre-os is Windows xp,the intended os is fedora9.0

comment:15 Changed 5 years ago by Brandon

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Priority changed from minor to blocker

I encountered the same error using 2.7 version, i corrected the root=UUID to root=device to /dev/sdx1 as x being the actual device where the fedora live is located in the syslinux.cfg file, and it works just beautifully, this new UUID identification process is a pain in the ...

comment:16 Changed 5 years ago by anonymous

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hello, same problem here. I have a box with sda, sdb, sdc (usbdisk). I used liveusb-creator 2.7 First boot attempt showed: Cannot find root file system So I changed syslinux.cfg (note that I had to use "sda1" for this to work) to:

append initrd=initrd0.img root=/dev/sda1 rootfstype=vfat rw quiet liveimg overlay=UUID=492B-89AD rhgb

but now the problem is that I get mount: you must specify the filesystem type umount: /overlayfs: not mounted

comment:17 Changed 5 years ago by depassp@…

I have reproduced this using liveusb-creator-2.7 on WindowsXP Pro (SP3).

Toshiba 40GB Hard Drive mounted in a generic mini-IDE-to-USB adapter. The disk has 2 partitions: 36GB (file storage), 750MB (attempted boot drive)

WindowsXP detects these as G: and I:, respectively.

Initially, liveusb-creator would not detect I:, and I had to "--force I:"

liveusb-creator then detects the UUID as 4008-878D (and accordingly writes this to syslinux.cfg

After attempting to boot, get the error "Cannot find root file system"

/lib/udev/vol_id -u /dev/sdb2

returns

F83B-4EA7

I suspect liveusb-creator is not detecting the correct UUID.

Furthermore, the UUID's of my other partitions are as follows:

DeviceUUID
/dev/sdb1476C-CEB3
/dev/sda27AD6CF89D6CF445B

The UUID detected by liveusb-creator (4008-878D) does not appear on any device, so it really must be confused.

comment:18 Changed 5 years ago by depassp@…

Perhaps liveusb-creator should use the (slightly more clumsy) partition label identifier "LABEL=" for syslinux, rather than UUID, and possibly force the user to rename the partition to something seemingly-unique (like F10-Live-USB)?

comment:19 Changed 5 years ago by lmacken

So yeah, this looks like it could be due to a problem with the Windows UUID detection code... Defaulting to a LABEL instead of a UUID may fix this for some cases, but I'm still curious as to why the UUID detection code is not consistent:

import win32com.client
uuid = win32com.client.Dispatch("WbemScripting.SWbemLocator") \
               .ConnectServer(".", "root\cimv2") \
               .ExecQuery("Select VolumeSerialNumber from "
                          "Win32_LogicalDisk where Name = '%s'" %
                          drive)[0].VolumeSerialNumber

Yes, that makes my eyes bleed -- but it has worked for me on many machines with many different types of USB sticks.. Suggestions welcome.

comment:20 Changed 5 years ago by anonymous

I encountered the same problem as described here on my first attempt to create a Live USB drive. The USB drive was originally formated NTFS and had to be reformated before being used. I performed a format from Windows while liveusb-creator was already loaded then selected build. When I attempted to boot from the USB drive I received the "able to find root file system" error. I reformated from windows, re-ran liveusb-creator and everything worked. I have been able to RECREATE this problem by formatting the USB drive after loading liveusb-creator it will then build with the previous volume label instead of the new one created by the format. The problem appears to be that you are reading the volume label during program startup and not during the build when you are writing the syslinux.cfg file.

F10-i686-Live.iso selected
Verifying filesystem...
Unsupported filesystem: NTFS
Please backup and format your USB key with the FAT filesystem.
LiveUSB creation failed!

Verifying filesystem...
Extracting live image to USB device...
Configuring and installing bootloader...
Complete! (0:01:21)

comment:21 Changed 5 years ago by anonymous

  • Milestone v2.0 deleted

Milestone v2.0 deleted

comment:22 Changed 5 years ago by lmacken

I just released version 3.1 of the liveusb-creator, which may fix this problem. Please try and reproduce this issue with the latest version. Thanks!

comment:23 Changed 5 years ago by federicocalzada@…

I'm experiencing this bug with v3.2 and Fedora 10.

comment:24 Changed 5 years ago by ArcticRaiders

I just downloaded both the latest version of Fedora(10), and also the liveusb-creator(3.2) and am having this same problem. I also had pendrivelinux on my usb drive, which I did a quick format on before I tried the liveusb-creator. I did also try another one that was just used for files in the past.

syslinux.cfg

default vesamenu.c32
timeout 100

menu background splash.jpg
menu title Welcome to F10-i686-Live!
menu color border 0 #ffffffff #00000000
menu color sel 7 #ffffffff #ff000000
menu color title 0 #ffffffff #00000000
menu color tabmsg 0 #ffffffff #00000000
menu color unsel 0 #ffffffff #00000000
menu color hotsel 0 #ff000000 #ffffffff
menu color hotkey 7 #ffffffff #ff000000
menu color timeout_msg 0 #ffffffff #00000000
menu color timeout 0 #ffffffff #00000000
menu color cmdline 0 #ffffffff #00000000
menu hidden
menu hiddenrow 5
label linux0
  menu label Boot
  kernel vmlinuz0
  append initrd=initrd0.img root=UUID=0859-5989 rootfstype=vfat rw liveimg overlay=UUID=0859-5989 quiet  rhgb 
menu default
label check0
  menu label Verify and Boot
  kernel vmlinuz0
  append initrd=initrd0.img root=UUID=0859-5989 rootfstype=vfat rw liveimg overlay=UUID=0859-5989 quiet  rhgb check
label memtest
  menu label Memory Test
  kernel memtest
label local
  menu label Boot from local drive
  localboot 0xffff

let me know if you need any more information.

comment:25 Changed 5 years ago by shaunakde@…

I was facing the same issue, but it was resolved by using the latest versions of liveusb-creator and fedora, and by formating the drive with the "Quick Format" option deselected.

comment:26 Changed 5 years ago by anonymous

Had this problem with f10 and v3.2 after formatting with "Quick Format" - I had previously had Ubuntu 8.10 on the drive. After I formatted without "Quick Format" and recreated everything worked fine.

comment:27 Changed 5 years ago by Martyn

I tried also format it but sometimes it work and sometimes it doesn't. i notice that the drive letter keep on changing when I switch the thumbdrives.

comment:28 Changed 5 years ago by lmacken

Please try and reproduce this issue with the latest version of the liveusb-creator. Thanks!

comment:29 Changed 5 years ago by azevedof@…

  • Priority changed from blocker to critical
  • Milestone set to v4.0

I have the following trouble when i tried to install Fedora 10 created with Fedora LiveUSB 3.6.3 (https://fedorahosted.org/releases/l/i/liveusb-creator/liveusb-creator-3.6.3.zip) in a HP Mini-Note 2133 Notebook. Everything looked ok during install, restarted the PC, get the booting count down and splash screen. After some seconds then get this:

*


WARNING: Cannot find root file system!


Create symlink /dev/root and then exit this shell to continue the boot sequence

bash: no job control in this shell bash-3.2#

*

PLEASE!! Help me to fix this bug step by step. Feel free to write me to my email azevedof@… Thanks so much!!

comment:30 Changed 5 years ago by Caroline Meeks

I am also having this problem intermittently. I can reburn the same USB with the same image on the same windows machine and sometimes it will occur and sometimes it won't.

comment:31 Changed 5 years ago by beland

  • Cc beland@… added

I am seeing this problem with liveusb-creator-3.6.5-2.fc11.noarch (Fedora 11 Preview, both host and LiveUSB image).

comment:32 Changed 4 years ago by lmacken

  • Status changed from reopened to closed
  • Resolution set to fixed

This should be resolved with version 3.9 of the liveusb-creator. Please re-open this bug if you are still encountering this problem. Thanks!

Note: See TracTickets for help on using tickets.