Ticket #125 (closed enhancement: fixed)

Opened 5 years ago

Last modified 5 years ago

noarch subpackage support

Reported by: mikeb Owned by: mikeb
Priority: minor Milestone:
Component: hub Version: devel
Keywords: Cc:
Blocked By: Blocking:

Description

This is a proposal to support noarch subpackages in Koji. This is a new feature of rpm, and requires support in the buildsystem. There are some outstanding questions to answer, including:

  • which arch build to use when importing the noarch rpm
  • what to do if different arches build noarch subpackages with different contents
  • what to do if one arch builds a noarch subpackage and one doesn't

Attachments

rpmdiff.py (7.9 KB) - added by ffesti 5 years ago.
stand alone rpmdiff code

Change History

Changed 5 years ago by ffesti

stand alone rpmdiff code

comment:1 Changed 5 years ago by ausil

  • Status changed from new to closed
  • Resolution set to fixed

this landed in koji 1.3

Note: See TracTickets for help on using tickets.