Ticket #3175 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

ipa-adtrust-install checks for /usr/bin/smbpasswd, which is not required

Reported by: steeve Owned by: tbabej
Priority: minor Milestone: FreeIPA 3.0.1 (bug fixing)
Component: Trusts Version:
Keywords: Cc:
Blocked By: Blocking:
Affects Documentation: no Patch posted for review: no
Red Hat Bugzilla: 867677 Patch review by:
External tracker: Design link:
Test coverage: Test by:
Test case: Needs UI design:
Feature: Source:
Expertise:
Release Notes:

Description (last modified by dpal) (diff)

[root@rasalghul ~]# rpm -qa | grep samba
samba-winbind-4.0.0-153.fc18.rc2.x86_64
samba-common-4.0.0-153.fc18.rc2.x86_64
samba-python-4.0.0-153.fc18.rc2.x86_64
samba-winbind-clients-4.0.0-153.fc18.rc2.x86_64
samba-libs-4.0.0-153.fc18.rc2.x86_64
samba-4.0.0-153.fc18.rc2.x86_64

[root@rasalghul ~]# yum install freeipa-server-trust-ad 
Package freeipa-server-trust-ad-3.0.0-2.fc18.x86_64 already installed and latest version
Nothing to do

[root@rasalghul ~]# ipa-adtrust-install

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will setup components needed to establish trust to AD domains for
the FreeIPA Server.

This includes:
  * Configure Samba
  * Add trust related objects to FreeIPA LDAP server

To accept the default shown in brackets, press the Enter key.

<type 'file'> was not found on this system
Please install the 'samba' packages and start the installation again
Aborting installation.

[root@rasalghul ~]# ls -l /usr/sbin/smbd /usr/bin/net /usr/bin/smbpasswd
ls: cannot access /usr/bin/smbpasswd: No such file or directory
-rwxr-xr-x. 1 root root 888336 Oct 10 18:54 /usr/bin/net
-rwxr-xr-x. 1 root root  62640 Oct 10 18:54 /usr/sbin/smbd

Change History

comment:1 Changed 3 years ago by dpal

  • Description modified (diff)

comment:2 Changed 3 years ago by dpal

  • Priority changed from major to minor
  • Milestone changed from 0.0 NEEDS_TRIAGE to 3.0.1

comment:3 Changed 3 years ago by dpal

  • Red Hat Bugzilla set to [https://bugzilla.redhat.com/show_bug.cgi?id=867677 867677]

Ticket has been cloned to Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=867677

comment:4 Changed 3 years ago by tbabej

  • Status changed from new to assigned
  • Owner changed from someone to tbabej

comment:5 Changed 3 years ago by tbabej

  • Status changed from assigned to closed
  • Resolution set to duplicate

This is a duplicate of https://fedorahosted.org/freeipa/ticket/3181 which has been resolved already.

comment:6 Changed 2 years ago by mkosek

  • Component changed from trusts to Trusts

Rename "trusts" component to "Trusts" to achieve correct sorting.

Note: See TracTickets for help on using tickets.