Ticket #1630 (closed defect: worksforme)

Opened 3 years ago

Last modified 2 years ago

ipa-ldap-update hangs, install hangs

Reported by: jdennis Owned by: rcritten
Priority: major Milestone: FreeIPA 2.2 Core Effort - 2012/01
Component: IPA Version:
Keywords: Cc:
Blocked By: Blocking:
Affects Documentation: no Patch posted for review: no
Red Hat Bugzilla: 0 Patch review by:
External tracker: Design link:
Needs UI design: Fedora test page:
Feature: Source:
Expertise:
Release Notes:

Description

While trying to upgrade my f15 test vm with the ipa 2.1 release candidate ipa-ldap-update hung and prevented the install from proceeding. Note, yum was upgrading a lot of new packages at the time including 389-ds, pki-code, xmlrpc-c curl, all the ipa packages, etc.

The ipaupdate.log file showed this as the last entry:

INFO Creating task to index attribute: memberHost

Rich M. examined the 389-ds logs and logged in and attached to the 389-ds process in gdb to diagnose but was unable to ascertain anything (in part because the 389-ds debug packages were not installed.

We also tried to perform an ldap search using ldapi (because during the update ports are turned of) to examine the tasks, but after 389-ds authenticated the directory manager the ldap search also hung.

Attachments

58478.txt (22.2 KB) - added by jdennis 3 years ago.
backtrace of all threads in 389-ds when hang occurred

Change History

Changed 3 years ago by jdennis

backtrace of all threads in 389-ds when hang occurred

comment:1 Changed 3 years ago by dpal

  • Milestone changed from 0.0 NEEDS_TRIAGE to 2.1 - Sprint 3. July
  • Priority changed from major to blocker

comment:2 Changed 3 years ago by rcritten

  • Milestone changed from 2.1 - Sprint 3. July to 2.1.1 - Bug fixing iteration 1

This seems to be related to https://fedorahosted.org/freeipa/ticket/1635

Risk seems low enough that not changing our plugins to use pthreads RW lock is acceptable for now, pushing to 2.1.1.

comment:3 Changed 3 years ago by rcritten

The 389-ds team is working on a fix for the memberOf plugin.

comment:4 Changed 3 years ago by rcritten

  • Milestone changed from 2.1.1 - Bug fixing iteration 1 to 2.1.2 - Bug fixing iteration 2

Rich thinks there is still a remote possibility of this happening but much less so since Nalin switched to pthread read-write locks. The IPA plugins changed as wel.

Keeping open for now but risk is considered low.

comment:5 Changed 3 years ago by rcritten

  • Milestone changed from 2.1.2 - Bug fixing iteration 2 to 3.0 Core Effort Iteration 03 November Y11
  • Priority changed from blocker to major

Dropping priority and pushing to 3.0. This is mostly a tracker to await 389-ds modifying its internal read/write locks.

comment:6 Changed 2 years ago by rcritten

  • Milestone changed from 3.0 Core Effort Iteration 03 November Y11 to 3.0 Core Effort Iteration 05 January Y12

comment:7 Changed 2 years ago by dpal

  • Red Hat Bugzilla set to 0

comment:8 Changed 2 years ago by rcritten

  • Status changed from new to closed
  • Resolution set to worksforme

This has not been seen since its first report. Closing until it is reproduced again.

Note: See TracTickets for help on using tickets.