Ticket #960 (closed task: fixed)

Opened 18 months ago

Last modified 17 months ago

F18 schedule + the holidays

Reported by: notting Owned by:
Priority: major Keywords: meeting
Cc: jreznik, rbergero, ausil, nirik, kevin, spot, adamwill, jdulaney, tflink Blocked By:
Blocking:

Description

phenomenon

The current F18 schedule has a release date of 12/11, which leaves one week of 'normal' slip space in the schedule before we run into the holidays.

I would like to start a discussion to frame what further slips might mean, and what options there would be (slip less than a week, etc.)

CC'ing major stakeholders here who would be involved.

Change History

comment:1 Changed 18 months ago by notting

  • Cc adamwill added; adamw removed

comment:2 follow-up: ↓ 3 Changed 18 months ago by jreznik

We have several options:

  • for fedup not being ready Kevin proposed to freeze once the testable fedup is available, then continue with standard process - this could give us at least this week, not a one week long slip before freeze
  • final go/no-go is historically on Tuesday (instead of Wed, now Thursday) as a buffer in case something goes wrong. The question for infra is if mirroring can start before Thursday? In this case the latest 2012 date could be Fri 12/21 (and not 24th)... Means another week.
  • shrink the Beta/Final? Change Deadline - is there really need for three weeks (11-06 and 11-26) - and not only for this release but generically what changes do we want between Beta and final for the future releases...

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 5 Changed 18 months ago by kevin

Replying to jreznik:

We have several options:

  • for fedup not being ready Kevin proposed to freeze once the testable fedup is available, then continue with standard process - this could give us at least this week, not a one week long slip before freeze

Yeah, only likely to buy us a week at most. ;)

  • final go/no-go is historically on Tuesday (instead of Wed, now Thursday) as a buffer in case something goes wrong. The question for infra is if mirroring can start before Thursday? In this case the latest 2012 date could be Fri 12/21 (and not 24th)... Means another week.

Mirroring could start on a friday for a tuesday release I think. But the important part there is that there has to be a "go" before we can start mirroring. So, at most moving this from thursday to friday buys us a day...

  • shrink the Beta/Final? Change Deadline - is there really need for three weeks (11-06 and 11-26) - and not only for this release but generically what changes do we want between Beta and final for the future releases...

We could try shrinking there, but:

a) Even if we froze right now say we still have some known blockers, so we couldn't even start doing rc's yet (even if the updates part was 100% blocker free).

b) For final there are other things that get done in that period... updating common bugs, finalizing websites, etc. Those could be affected if the window was smaller there.

Really we need to start working really hard to stop the slipping...

comment:4 Changed 18 months ago by adamwill

FWIW, I tend to be the one who does most of the work on commonbugs, and I usually do it between the go/no-go meeting and the ship date (that period is a pretty slack one for QA). So the length of any other period isn't particularly relevant to commonbugs work.

comment:5 in reply to: ↑ 3 ; follow-up: ↓ 8 Changed 18 months ago by jreznik

Replying to kevin:

Replying to jreznik:

We have several options:

  • for fedup not being ready Kevin proposed to freeze once the testable fedup is available, then continue with standard process - this could give us at least this week, not a one week long slip before freeze

Yeah, only likely to buy us a week at most. ;)

Every week is priceless now ;-)

  • final go/no-go is historically on Tuesday (instead of Wed, now Thursday) as a buffer in case something goes wrong. The question for infra is if mirroring can start before Thursday? In this case the latest 2012 date could be Fri 12/21 (and not 24th)... Means another week.

Mirroring could start on a friday for a tuesday release I think. But the important part there is that there has to be a "go" before we can start mirroring. So, at most moving this from thursday to friday buys us a day...

Well, I talked to Dennis - for mirroring we need three days at least. We have final go/no-go on Tuesday, so looks like not an option - as I'm not sure how would go/no-go work on Monday.

  • shrink the Beta/Final? Change Deadline - is there really need for three weeks (11-06 and 11-26) - and not only for this release but generically what changes do we want between Beta and final for the future releases...

We could try shrinking there, but:

a) Even if we froze right now say we still have some known blockers, so we couldn't even start doing rc's yet (even if the updates part was 100% blocker free).

Yep, but it could buy us another week (and there would be still week buffer).

b) For final there are other things that get done in that period... updating common bugs, finalizing websites, etc. Those could be affected if the window was smaller there.

Good point, I'll ask people what they think about it and if we could ask them to start earlier etc.

Really we need to start working really hard to stop the slipping...

It's the problem of where in the stack we are delayed. Now it's Anaconda - that means the first thing you hit... And there's no magic to make it working with such constrained resources (sorry, developers) :(

comment:6 follow-up: ↓ 7 Changed 18 months ago by ausil

As I see it we can ship Dec 11, Dec 18, after that we will have to go to Jan 15 then Jan 29 I am ruling out Jan 22 as a possible release date due to FUDCon NA being right before it. Right now we are scheduled to ship Dec 11 what do we need to make that date?

comment:7 in reply to: ↑ 6 Changed 18 months ago by jreznik

Replying to ausil:

As I see it we can ship Dec 11, Dec 18, after that we will have to go to Jan 15 then Jan 29 I am ruling out Jan 22 as a possible release date due to FUDCon NA being right before it.

One idea was to be able to ship also Dec 22. Or then as close as possible after Christmas - Jan 8 (very tight...).

Right now we are scheduled to ship Dec 11 what do we need to make that date?

See ticket 946

comment:8 in reply to: ↑ 5 Changed 18 months ago by mitr

Replying to jreznik:

Replying to kevin:

Replying to jreznik:

  • shrink the Beta/Final? Change Deadline - is there really need for three weeks (11-06 and 11-26) - and not only for this release but generically what changes do we want between Beta and final for the future releases...

We could try shrinking there, but:

a) Even if we froze right now say we still have some known blockers, so we couldn't even start doing rc's yet (even if the updates part was 100% blocker free).

Can we (and should we?) work on finding and/or fixing the non-anaconda blockers without freezing Beta?

comment:9 Changed 18 months ago by adamwill

We've been working on finding and fixing blockers for three weeks already. We start doing that right from when we do TCs.

comment:10 Changed 18 months ago by limb

#agreed Continue to hope for no slips, if we do, then then reevaluate then. Keep ticket open for ideas/etc. (+:5,-:0,0:0)

comment:11 Changed 18 months ago by mattdm

So:

There's a lot of good stuff in this release. It's also got a very big change to the installer, and systemd is jumping from version 44 to version 195, and we've got a new Gnome version, and there's this firewall daemon thing, and etc.

It's unfortunate to miss 2012 entirely, but that might be better than a trouble-ridden release. Is it crazy talk to start thinking seriously about January 15th?

comment:12 Changed 18 months ago by adamwill

Well, I'd say the chances of us saying Go on Thursday right now are approximately 1%. So maybe not.

comment:13 Changed 18 months ago by jreznik

I talked to Dennis, it would be possible to release on 23th this year (definitely not 24th). For cutting out the week between beta and final change deadline - I checked with docs guys, it should be feasible, Adamw stated here it would be ok for CommonBugs?, websites team to be checked. I think this could be a good question for readiness meeting as most of the folks should be there. And seems we will need the week at least...

comment:14 Changed 18 months ago by kevin

At today's FESCo meeting we decided to:

AGREED: if we slip on Thursday, pull 1 week from schedule after beta release but before final freeze

ie, this means that beta would slip a week, but all the milestones after would stay the same.

Developers would have one less unfrozen week between beta release and final freeze.

Keeping this ticket open to keep revisiting.

comment:15 Changed 18 months ago by jdulaney

  • Cc jdulaney added

comment:16 Changed 18 months ago by rbergero

From a marketing POV: Releasing on the 23rd is not optimal. Press release will be non-existent/read by nobody, and all of the other associated stuff (interviews, reviews, news articles, etc.) will likely suffer - reporters aren't going to want to spend their holidays writing things up, they also aren't too hip on writing on things that they get pre-briefed on or do pre-release-interviews on when few people are going to read them. Even simple things like "the release announcement" - plenty of people don't read news on Sundays as it is, let alone what's piled up in their inbox between the friday before and the day or two after the 25th - I'm afraid that releasing on the 23rd/Sunday is just going to result in nobody knowing there's a release.

Jan. 8 seems like it could be a reasonable target - but assumes a lot in terms of the availability of people to fix blocker bugs in the time leading up to it. Dec. 11, 18 are obviously more optimal if we have to push to those dates; if we are really out at Jan. 15 and have to push out, I would rather see us suck it up and share the load and figure out how to get it out in spite of FUDCon going on vs. pushing out another week on top of that.

comment:17 Changed 17 months ago by tmraz

  • Resolution set to fixed
  • Status changed from new to closed

The F18 schedule as decided on 2012-11-07 FESCo meeting is:

unfreeze now (2012-11-07), freeze (tentative) 2012-11-13, beta release 2012-11-27

final change deadline 2012-12-18, release 2013-01-08

comment:18 Changed 17 months ago by ausil

Just wanted to make sure that everyone was aware that a shipping date of 2013-01-08 means we have to have the release done and ready to ship before Christmas. which is why my initial comment on this thread said that after Christmas the first viable date is 2013-01-15. the reason for this being the Red Hat shut down from 2012-12-24 through 2013-01-02 we have to put the bits on the mirrors on 2013-01-03 so if QA is not done before Christmas we have zero time to do anything after shutdown and will have to slip to the 15th or the 29th after that.

comment:19 Changed 17 months ago by ausil

  • Resolution fixed deleted
  • Status changed from closed to reopened

Ok so i just looked at this closer with the Red Hat shutdown and a change freeze on the 18th we have 3 days to get the release done. it will then sit there for the shutdown period to be staged and shipped on the 8th. I do not think the 8th is realistic or feasible as a shipping date. there will not be most people around from Dec 24 through Jan 1.

I think we need to just move the release date from the 8th to the 15th of January. If we really want to stick to the 8th of January then we have to make the change freeze the 11th of December so that we can make sure all blockers are fixed before most people disappear for the break.

comment:20 Changed 17 months ago by tflink

  • Cc tflink added

comment:21 Changed 17 months ago by jreznik

Well, as FESCo agreed to release on Wed and Thu too - it means we could have one/two more days in the beginning of January. It's not too much though.

For freeze next week - I'd like to ask QA how they feel about it (while looking on proposed blocker bug list), Adam, Tim?. The first test compose should be ready this week and actually I'm not against freezing earlier as it's final change deadline and I prefer more stabilisation work on F18 now, not a heavy development.

Otherwise with release dates flexibility - we should be able to run release machinery during FUDCon too - with Go/No?-Go on Friday.

comment:22 Changed 17 months ago by jreznik

Btw. from the schedule final Go/No?-Go is (probably from historical reasons) planned on Tue but I expect we will follow Thursday (or Friday) one.

For the proposed/accepted bugs list - it's in quite a limited set of components (accepted are currently mostly in anaconda itself).

comment:23 Changed 17 months ago by notting

  • Resolution set to fixed
  • Status changed from reopened to closed

From the 2012-12-05 FESCo meeting:

  • AGREED: Allow deferment of fedup gui until F19 (+:8, -:0, 0:0)
  • AGREED: Do not block on fedup signature checking (not a regression) (+:7, -:0, 0:0)
  • AGREED: (960) Final change deadline moved from 12/18 to 12/11. Release date remains 01/08. (+:6, -:3 0:0)

Given that, closing this.

Note: See TracTickets for help on using tickets.