Ticket #594 (closed zFeature: fixed)

Opened 4 years ago

Last modified 4 years ago

F16Feature: F16 BTRFS default file system - http://fedoraproject.org/wiki/Features/F16BtrfsDefaultFs

Reported by: rbergero Owned by:
Priority: major Keywords: meeting
Cc: josef Blocked By:
Blocking:

Description

For 2011-06-01 meeting

Change History

comment:1 Changed 4 years ago by kevin

We will be discussing this at the meeting tomorrow again.

comment:2 Changed 4 years ago by josef

Encryption - We work just fine on dm-crypt, it's just that dm-crypt had problems where it wouldn't pass down barriers at one point so if you lost power you were hosed.

Quota - Work has started but it likely won't be ready by F16

Anaconda - Everything works fine currently, but no access to cool btrfs features. This is more up to the anaconda people than me. I can add support for various things, but as for how to wire them up in the GUI that is going to require more input than just mine.

RAID5/6 - Not sure why this even on the table, it isn't necessary for a working system.

Recovery strategy - A fsck tool is almost ready, part of the reason it is taking so long is it is being very well tested, so when it does ship it will have been run through several hundred broken fs's to make sure it works properly.

comment:3 Changed 4 years ago by mbroz

"it's just that dm-crypt had problems where it wouldn't pass down barriers at one point so if you lost power you were hosed"

As asked at least two times, please either provide reproducer or remove that statement. Any reference in mailing-list with reproducer?

Barriers/flush works in dm-crypt, there is no such problem to the best of my knowledge.

comment:4 Changed 4 years ago by josef

There aren't problems currently no, but there were problems before. I don't have reproducers or anything. Keep in mind that the btrfs wiki is a _wiki_, anybody can add stuff to that page.

comment:5 Changed 4 years ago by kevin

  • Status changed from new to closed
  • Resolution set to fixed

We added some base criteria we would like to make sure of by feature freeze, and also, this is just changing btrfs for ext4, not changing the setup of lvm or /boot or the like at this time (but if there is work done to do so, we would like to revisit).

Thanks.

Note: See TracTickets for help on using tickets.