Ticket #1255 (closed task: fixed)

Opened 15 months ago

Last modified 15 months ago

girara+zathura: update policy exception request

Reported by: fcami Owned by:
Priority: major Keywords: meeting
Cc: psabata Blocked By:
Blocking:

Description

Package Name: girara and zathura

FAS Name of maintainer: fcami, psabata and (sometimes) kevin

Background: Zathura (http://pwmt.org/projects/zathura/) is a document viewer, with plugins for PDF, PostScript?, DjVu?, etc. Zathura depends on a library, girara (http://pwmt.org/projects/girara/), which is a front-end for gtk2/3. Girara doesn't seem to be used outside of pwmt.org-hosted projects.

Zathura users tend to want the latest version - I often get bugs asking for an update.

But to keep zathura and plugins up to date, girara must be upgraded as well more often than not, and upgrading girara sometimes means breaking ABI, which is against the policy:

https://fedoraproject.org/wiki/Updates_Policy#All_other_updates

I think both girara and zathura should be granted a policy exception because:

  • the printing bugs fixed in the latest zathura are problematic for our users: http://pwmt.org/projects/zathura/changelog/0.2.7
  • we cannot update any stable branch without breaking ABI, girara having moved to gtk2/gtk3 to gtk3-only. This means keeping an older zathura in Fedora for about a year from now.
  • there is no software that I know of using girara except zathura.
  • Petr and I both maintain the whole girara/zathura/zathura-plugins stack and so we can easily upgrade all the packages in a single erratum.

Change History

comment:1 Changed 15 months ago by psabata

  • Cc psabata added

comment:2 Changed 15 months ago by kevin

  • Keywords meeting added

comment:3 Changed 15 months ago by kevin

  • Status changed from new to closed
  • Resolution set to fixed

exception granted (+6,0,0)

Wiki page updated as well (feel free to tweak it)

comment:4 Changed 15 months ago by fcami

Awesome, thank you!

Note: See TracTickets for help on using tickets.