Ticket #1094 (closed maintainer issue: fixed)

Opened 14 months ago

Last modified 13 months ago

tomcat6 deprecation (fasttrack)

Reported by: sochotni Owned by:
Priority: major Keywords: meeting
Cc: Blocked By:
Blocking:

Description

tomcat6 hasn't been updated in a long time (since June 2012), it has several security bugs which should be addressed etc. With introduction of automatic requires in Java land it's also causing some FTBFSs (mixing of tomcat-7.x and tomcat6 artifacts). Migration of tomcat6 packages is mostly trivial.

As noted in devel ML[1] I would like to possibly speed up the orphaning process in rawhide. I am in contact with few more people interested in tomcat6 in older Fedoras and if David doesn't get back soon(ish), we'll do the updates in F17/F18. But tomcat6 in rawhide should go buh-bye ASAP.

[1] http://lists.fedoraproject.org/pipermail/devel/2013-March/179847.html

Change History

comment:1 Changed 14 months ago by mmaslano

The package should be orphaned long time ago.

+1 from me, I won't attend the meeting

comment:2 Changed 14 months ago by akurtakov

Tomcat6 package has costed way too much invaluable time to people taking care of the Java stack while being unmaintained for such a long time that killing it immediately would be too slow :).

comment:3 Changed 14 months ago by notting

  • Keywords meeting added

comment:4 Changed 14 months ago by sochotni

I managed to contact David. Situation is not ideal, but we've waited long enough so my proposal:

  • If tomcat6 in F19/rawhide is not fixed with regards to security issues and clashing provides for J2EE javax-XX stuff, reassign to myself (I'll deprecate the package in F19+ and file bugs for packages to migrate)
  • tomcat6 in F17/F18 will receive security fixes

Both points have deadline before next FESCO meeting (March 20th). I'll try to coordinate with David wrt security patches so they can be sent out ASAP (by end of the week ideally).

Can't attend the meeting unfortunately, but I'll read the log and reply to discussion here if needed.

comment:5 Changed 14 months ago by notting

From 2013-03-13 FESCo meeting - agreed to wait one week and revisit.

comment:6 Changed 13 months ago by sochotni

So a summary of last week:

  • tomcat6 has been deprecated in F19/rawhide
  • F17 and F18 are receiving updates[1]
  • I started mentoring new packagers that would eventually help specifically with maintaining tomcat6 (and possibly tomcat-7.x if the maintainer won't object)

From my POV this ticket can be closed, but I'll leave that up to you

[1] https://admin.fedoraproject.org/updates/search/tomcat6

comment:7 Changed 13 months ago by kevin

  • Status changed from new to closed
  • Resolution set to fixed

Excellent. Thanks for bringing things to a good conclusion.

Note: See TracTickets for help on using tickets.