Ticket #184 (new defect)

Opened 5 years ago

Last modified 5 years ago

missing search and dropdown filters

Reported by: duffy Owned by: johnp
Priority: blocker Milestone: v2.0
Component: Widgets Version:
Keywords: Cc:
Blocked By: Blocking:

Description

in many cases the dropdowns are

display: [ Rawhide | Fedora 10 | Fedora 9 | All Releases ]

or display: [ My Packages | Packages I Own | Packages I Maintain| All Packages ]

the search filters are a simple search filter to filter down the contents of the grid

Change History

comment:1 Changed 5 years ago by duffy

missing on package maintenance > packages

comment:2 Changed 5 years ago by duffy

missing for the following three pages: Package Maintenance > Builds > In Progress & Failed Builds & Successful Builds

comment:3 Changed 5 years ago by duffy

missing for package details > downloads and package details > maintainers

comment:4 Changed 5 years ago by duffy

missing for package details > builds, and for the builds table the releases dropdown should also include a 'scratch builds' option

comment:5 Changed 5 years ago by duffy

missing for package details > changelogs

comment:6 Changed 5 years ago by duffy

missing for package details > updates. this page has an additional dropdown filter:

https://fedoraproject.org/w/uploads/b/b1/Myfedora-packagedetails-updates-mock1.png

status: all | stable | testing & stable | obsolete

comment:7 Changed 5 years ago by duffy

  • Milestone changed from v1.0 to __future__

need to talk to upstream koji for future feature

comment:8 Changed 5 years ago by spot

  • Owner set to johnp
  • Milestone changed from __future__ to v1.0
  • Priority changed from major to blocker

Only scratch builds are future feature, everything else here is blocker.

comment:9 Changed 5 years ago by johnp

  • Milestone changed from v1.0 to v2.0

Builds needs some fixes to koji and bugs needs some connector work to be able to select versions. I'm going to open a new bug for luke on the bugs connector since it is 95% there but I'm not sure how to select version. Otherwise the rest is done moving to v2.0

Note: See TracTickets for help on using tickets.