Ticket #3523 (closed bug: fixed)

Opened 18 months ago

Last modified 17 months ago

Wiki captcha is NOT friendly for visually impaired people

Reported by: jskarvad Owned by: sysadmin-members
Priority: major Milestone: HANDWAVY-FUTURE
Component: General Version:
Severity: Normal Keywords:
Cc: Blocked By:
Blocking: Sensitive:

Description

bug description

Fedora Wiki captchas are NOT friendly for visually impaired people, so e.g. it is not possible for them to add link to external sites (e.g. this is used during some test days, e.g. smolt profiles links, etc.)

bug analysis

There is missing audio fallback in current CAPTCHA system used on Fedora Wiki.

fix recommendation

Please add audio fallback or switch to another CAPTCHA system (e.g. math solving that could be read by screen readers would be also OK).

Change History

comment:1 Changed 18 months ago by kevin

Well, we are using http://www.mediawiki.org/wiki/Extension:ConfirmEdit on the wiki, so we have the options listed there (Except recaptcha, which is non free and external).

I guess the best option is the math puzzle, but I don't know how easy they are to read by screen readers. ;(

Can you (or someone you know) test if I set that up in our staging instance?

comment:2 Changed 18 months ago by jskarvad

kevin, thanks for the prompt response. Could you provide the link to staging instance? I will forward it to people that could test.

comment:3 Changed 18 months ago by kevin

http://stg.fedoraproject.org/wiki/

I have set it to use the 'simple' captcha.

I am a bit worried that it's too simple and it will result in spam increasing, but we can try and it and back it out if that turns out to be the case.

Please let me know if this works for your testers and I can push it to production.

Also, as a side note: we have been looking for some usability feedback from blind users on our other applications. If the folks you know would be willing to look over other applications and give us feedback we can try and adjust them. :)

comment:4 Changed 18 months ago by jskarvad

Forwarded, waiting for response.

comment:5 Changed 18 months ago by kevin

Any news?

comment:6 Changed 18 months ago by jskarvad

I got no response (maybe because the use case is not trivial), but I think the proposed solution on staging (IIRC the previously used system) should fit (at least it is better than the current system).

comment:7 Changed 17 months ago by kevin

  • Status changed from new to closed
  • Resolution set to fixed

Moved to production.

Note: See TracTickets for help on using tickets.