Ticket #1202 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

Issues building in plague

Reported by: rayvd Owned by: ausil
Priority: major Milestone:
Component: Buildsys Version: Production
Severity: Normal Keywords: plague
Cc: laxathom, ondrejj, tmz Blocked By:
Blocking: Sensitive:

Description

I'm having troubles building several python packages in plague. No idea if this is related to yesterday's outage or not:

The latter is a known good package (pymssql) which hasn't been changed in a very long time and should build perfectly. pyodbc is recently updated but builds fine in a local mock environment.

Both are reporting dependency errors on python with something along the lines of the following:

 # /usr/bin/yum --installroot /var/lib/mock/fedora-5-ppc-epel-c02fd9339640920144f7a6e652d7a422d0ef43c4/root/  install  'python-devel >= 2.4' 'freetds-devel >= 0.63'
python-devel-2.4.3-19.el5.ppc from rhel5-base has depsolving problems
  --> Missing Dependency: python = 2.4.3-19.el5 is needed by package python-devel-2.4.3-19.el5.ppc (rhel5-base)
Error: Missing Dependency: python = 2.4.3-19.el5 is needed by package python-devel-2.4.3-19.el5.ppc (rhel5-base)

Of note is that -19 is not the current version of Python in my EL install, -21 is. Other jobs on plague seem to have completed correctly overnight, however none of them were python packages.

Hoping someone can take a look at this -- obviously not super critical ATM. Thanks!

Change History

comment:1 follow-up: ↓ 8 Changed 5 years ago by ausil

  • Status changed from new to assigned

there seems to be an issue with the repos we use to populate the buidlroots. a newer python is installed in the --init process. so yum rightly so says there is no python to install.

Working on fixing

comment:2 Changed 5 years ago by laxathom

  • Cc laxathom added

comment:3 Changed 5 years ago by rayvd

Just a ping on this -- this still appears to be an issue ([http://buildsys.fedoraproject.org/logs/fedora-5-epel/1580-pyodbc-2.1.4-4.el5/ log).

I guess if the switch to koji is close this doesn't matter. :)

comment:4 Changed 5 years ago by laxathom

we won't block anything even if we'll move to koji. we're still working on a fix.

comment:6 Changed 5 years ago by ondrejj

  • Cc ondrejj added

comment:7 Changed 5 years ago by tmz

  • Cc tmz added

Just in case it helps, here's a case where the same package built successfully on EL-4 and failed on EL-5:

http://buildsys.fedoraproject.org/logs/fedora-4-epel/1803-puppet-0.24.8-1.el4/ (passed) http://buildsys.fedoraproject.org/logs/fedora-5-epel/1802-puppet-0.24.8-1.el5/ (failed)

Puppet was last built successfully on both EL branches on December 16, using the same versioned ruby BRs.

comment:8 in reply to: ↑ 1 Changed 5 years ago by ondrejj

Replying to ausil:

Working on fixing

Ping. It's more than a month from this message and problem still present.

comment:9 follow-up: ↓ 10 Changed 5 years ago by ausil

as a work around remove the versioned BuildRequires?.

comment:10 in reply to: ↑ 9 Changed 5 years ago by ondrejj

Replying to ausil:

as a work around remove the versioned BuildRequires?.

OK, at least this works for me. Thank you.

comment:11 follow-up: ↓ 12 Changed 5 years ago by rayvd

This appears to work for me as well. I guess you don't really need versioned BuildRequires anyways if you have versioned Requires.

comment:12 in reply to: ↑ 11 Changed 5 years ago by ondrejj

Replying to rayvd:

This appears to work for me as well. I guess you don't really need versioned BuildRequires anyways if you have versioned Requires.

I think it's not a good idea. When building an package, it can say what's wrong at build time and it avoids packages, which are built OK, but doesn't work.

If this will be approved as real solution, this should go into fedora packaging guidelines.

comment:13 Changed 5 years ago by rayvd

I didn't feel like maintaining two versions of my .spec file for EPEL and Fedora so I just updated the Fedora .spec's to match. Maybe not best practice but only way I can get this stuff updated in EPEL currently.

Could a situation arise where mock would be able to pull in a different version of the BuildRequires packages than were specified in Requires? I wouldn't think so unless the packages themselves are fouled up...

comment:14 Changed 5 years ago by ausil

  • Status changed from assigned to closed
  • Resolution set to fixed

a new yum has been deployed on the builders that resolves the versioned BuildRequires? resolving.

Note: See TracTickets for help on using tickets.