Ticket #39 (assigned task)

Opened 4 years ago

Last modified 2 years ago

Subtask for ticket #19 (bundled libraries) -- C

Reported by: toshio Owned by: thom
Priority: major Milestone:
Severity: Simple Keywords:
Cc: robbieab Blocked By:
Blocking:

Description

I'm categorizing the bundled libraries according to programming language so that it's easier for people to know what they're working on without stepping on each other's toes. This ticket will be for bundling of C code.

Change History

comment:1 Changed 4 years ago by toshio

Need triaging

spring

https://bugzilla.redhat.com/show_bug.cgi?id=505636

Need to determine whether the lua modifications should be done to the system lua package. Need to modify to use the system version of the other libraries and code.

lua-sec

https://bugzilla.redhat.com/show_bug.cgi?id=551763

Need to know if we still need this or if we can just package nixio instead. If this is still needed/wanted, need to work to get a new release of luasocket from upstream -- if upstream is dead need to find someone to take over.

nip2

https://bugzilla.redhat.com/show_bug.cgi?id=622001

Bundles gtkextra. Need to figure out where that comes from and how to unbundle.

Need source code patch

php

https://bugzilla.redhat.com/show_bug.cgi?id=551513

php is bundling libzip. We need to figure out why it's been modified and then patch php to use the system version instead of the bundled version.

zsync

https://bugzilla.redhat.com/show_bug.cgi?id=490140

Bundles zlib. zlib has been modified. See the rsync entry. Note that the modifications to zlib done here are different than the ones done in rsync but they're supposed to serve the same purpose.

rsync

https://bugzilla.redhat.com/show_bug.cgi?id=495310

Bundles a modified copy of zlib. Need to get changes introduced to upstream zlib mailing list. I've searched the upstream zlib archives and not found any mention of these changes. Need to ask rsync maintainers to explain their changes so that we can discuss the changes intelligently with zlib upstream.

Xulrunner

https://bugzilla.redhat.com/show_bug.cgi?id=517856

Upstream is bundling a variety of media libraries. Need to unbundle these. Don't know if trademark issues hinder us here -- xulrunner is not the same as firefox.

tkImg ==

https://bugzilla.redhat.com/show_bug.cgi?id=548163

Preliminary patch exists but the software seg faults with it applied. Need someone to fix this up.

Need spec file patch

orage

https://bugzilla.redhat.com/show_bug.cgi?id=522788

Fixed upstream. Just need to incorporate the new release into future Fedoras. Not sure what to do about EPEL. The time to maintain in Fedora is only about 16 month (from rawhide branching from the previous release to EOL). The time to maintain in EPEL is much longer. nirik's looking into possibilities.

upx

https://bugzilla.redhat.com/show_bug.cgi?id=564522

Waiting on a static lzma-sdk build.

lzma-sdk

https://bugzilla.redhat.com/show_bug.cgi?id=596461

This is a review request

comment:2 Changed 4 years ago by toshio

vdrift

https://bugzilla.redhat.com/show_bug.cgi?id=621623

vdrift bundles bullet. need triage to determine if it's been modified.

comment:3 Changed 4 years ago by mmcgrath

  • Owner set to nhorman

Neil, let me know if you'd rather work on something else.

comment:4 Changed 4 years ago by toshio

New one came in today.

cabextract

https://bugzilla.redhat.com/show_bug.cgi?id=628147

Bundling libmspack. The bug report says "recent versions of cabextract already support linking with an external libmspack". So this should be a spec file change now.

comment:5 Changed 4 years ago by mmcgrath

nhorman: I haven't seen any updates in a bit, are you still able to work on this or should we hand it off to someone else?

comment:6 Changed 3 years ago by thom

  • Owner changed from nhorman to thom

Exception filed with Fedora Packaging Committee for PHP: https://fedorahosted.org/fpc/ticket/62

comment:7 Changed 3 years ago by thom

Some licensing issues with lzma-sdk are being worked out.

comment:8 Changed 3 years ago by thom

https://bugzilla.redhat.com/show_bug.cgi?id=504493 (Tracker: Duplication of system libraries)

Cabextract fixed in cabextract-1.3-1.fc14

comment:9 Changed 3 years ago by thom

orage fixed in f15

comment:10 Changed 3 years ago by thom

lzma-sdk awaiting FE-legal vdrift fixed in f16

comment:11 Changed 3 years ago by robbieab

  • Cc robbieab added

Looks good Thom, thank you for taking this on.

comment:12 Changed 3 years ago by thom

orage was fixed in orage--4.7.5.16 and includes both LIBICAL and TZDATA

vdrift was fixed in vdrift-20100630-3.fc16

comment:13 Changed 3 years ago by thom

lua-sec was marked as CLOSED - WONTFIX - removing from list

comment:14 Changed 3 years ago by thom

BTW, Prosody also marked CLOSED - WONTFIX

comment:15 Changed 3 years ago by thom

comment:16 Changed 3 years ago by thom

nip2 is awaiting word from upstream. Requested status update php exception is awaiting information from submitter. Requested update rsync, spring, xulrunner, zsync is awaiting word from assignee upx is awaiting information from spot

comment:17 Changed 3 years ago by thom

php zip was disabled to bring in line with policy

comment:18 Changed 3 years ago by thom

rsync: Vojtech is working with all interested parties to resolve this issue

comment:19 Changed 3 years ago by thom

spring: Gilboa is planning on filing an exception with FPC

comment:20 Changed 3 years ago by thom

upx: Spot sent email to Igor Pavlov about getting acceptable license

comment:21 Changed 3 years ago by thom

upx: Igor gave permission via email for LZMA-SDK to be used under LGPLv2

comment:22 Changed 3 years ago by thom

rsync and zsync: Vojtech has "...initiated a fresh conversation between Wayne Davison (rsync) and Mark Adler (zlib) off list /with few others CC'ed/. They are now discussing possible changes in zlib (deflate/inflate add dictionary context patches) to make rsync functionality inclusion possible."

comment:23 Changed 3 years ago by thom

xunrunner: On 04/26/2011 07:27 AM, Martin Stransky wrote: "AFAIK the Fedora system libraries miss some fixes which are needed for xulrunner. Technically we can build xulrunner with system libraries but the result will be unreliable. Plus we will need extra build patches to xulrunner. There are some upstream bugs for it, try to search upstrem bugzilla, IMHO some media libraries can be unbundled."

I asked "Is the best approach to unbundle those media libraries and file an exception for the remainder?" and the response was: "The best approach is to test firefox with the unbundled libraries and then decide."

comment:24 Changed 3 years ago by thom

spring: Gilboa unavailable until third week in May.

tklmg: Awaiting exception filing

comment:26 Changed 3 years ago by thom

tkimg: Thanks to Spot who said: "Pretty sure I have this one all resolved, with all the remaining bundled code stripped out. Tested it pretty extensively and it seems to all still work. It's not pretty, but then again, neither is tkimg. I'll push this as an update for Fedora 16+, and leave the older versions alone."

comment:27 Changed 3 years ago by thom

tkimg: 1.4.4.fc16 upx: rewritten by Spot, Jason set to review, needs Jon's approval nip2: Adam reported 7.24 improved situation

comment:28 Changed 3 years ago by thom

nip2: Asked Adam what remained to be done rsync/zsync: Asked Vojtech to check again with developer spring: Partial exception granted by https://fedorahosted.org/fpc/ticket/105. Asked Gilboa about remaining issues upx: Jon approved changes - awaiting Jason's review xulrunner: Still stalled out

comment:29 Changed 3 years ago by thom

php: Vedran reported removing zip broke Moodle rsync/zsync: Vojtech received reply from zlib upstream but is awaiting rsync upstream spring: Gilboa is awaiting upstream about streflop

comment:30 Changed 2 years ago by thom

PHP: James Heather said Moodle as bundled by Fedora just won't work any more. Vedran was pulling it in from CVS, but as of the release of Fedora 16, the Moodle release in the Fedora repo won't work because it needs the PHP zip extension.

Can we please have some sort of workaround for this? We shouldn't have programs distributed with Fedora that don't work with Fedora...

comment:31 Changed 2 years ago by thom

Vedran replied "I installed the extension manually (from PEAR IIRC) and now it works.

We should probably package that extension and add dependency to moodle package that we ship."

Note: See TracTickets for help on using tickets.