Ticket #36 (closed defect: wontfix)

Opened 6 years ago

Last modified 6 years ago

upgrading someone to "Sponsor" can be perfomed by any sponsor

Reported by: wolfy Owned by: ynemoy
Priority: major Milestone:
Component: Web UI Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Yesterday and today I have used for the first time my status of "sponsor" and tried to promote "kairo" (yesterday) and "davidf" (today) to members of cvsextras.
The steps I performed today (for user davidf, as stated above) were (please note that both yesterday and today access to this URL was very very very very slow - the page taking like 2 min to load; therefore I tried reloading it several times before having a complete page loaded):

Both today and yesterday the following actions were available: sponsor, remove,upgrade,downgrade. I pressed "upgrade" and waited. After a loooong long time davidf's "Role type" was changed to user, but 4 hours later the column "Approval" was still in "unapproved" state. Since yesterday (roughly 20 hours ago) both columns changed almost simultanously and because yesterday I did press once on the "sponsor" button (for kairo), I assumed I have to do it for davidf, too. 3 minutes later when the page reloaded his Role type was displayed as "Sponsor". After which I cried for help in #fedora-admin and abadger1999 manually fixed the mess.

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by ynemoy

  • Status changed from new to assigned
  • Owner changed from somebody to ynemoy

Does this bug still exist? can it be reproduced?

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 6 years ago by wolfy

Replying to ynemoy:

Does this bug still exist? can it be reproduced?

I do not know, I was afraid to to do it again. I was not at all tempted to create another mess.

comment:3 in reply to: ↑ 2 Changed 6 years ago by ynemoy

  • Status changed from assigned to closed
  • Resolution set to wontfix

Replying to wolfy:

Replying to ynemoy:

Does this bug still exist? can it be reproduced?

I do not know, I was afraid to to do it again. I was not at all tempted to create another mess.

I'm going to close it then. Unfortunately, I do not know how to reproduce it.

comment:4 Changed 6 years ago by ricky

I think there was some misunderstanding about the function of the "sponsor" and "upgrade" buttons. Sponsors are able to upgrade anybody to the sponsor role, but it is the "sponsor" button that actually approves the person into the group. The main problem that I see is that the role type column didn't immediately change after the user was upgraded (but we don't seem to be able to reproduce that anymore).

Note: See TracTickets for help on using tickets.