Ticket #620 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Buildroot overrides require commit access to devel branch rather than branch override applies to

Reported by: pghmcfc Owned by: lmacken
Priority: major Milestone: Fixed, but not yet deployed
Component: bodhi-server Version:
Keywords: Cc: ppisar, sochotni, tradej, pingou
Blocked By: Blocking:

Description

Buildroot overrides require commit access to devel branch rather than the branch override applies to.

For instance, I was trying to add an override for perl-GD in EPEL-4 but was refused as I only had commit access for the el4 branch. Once I got commit access for devel (perversely enough the only branch that doesn't actually *need* overrides) I was able to add the override. This seems wrong to me.

Change History

comment:1 Changed 3 years ago by iarnell

I think this should also take provenpackagers into account rather than requiring explicit user-based commit privileges to devel branch.

comment:2 Changed 3 years ago by ppisar

  • Cc ppisar added

comment:3 Changed 3 years ago by sochotni

  • Cc sochotni added

comment:4 Changed 3 years ago by tradej

  • Cc tradej added

comment:5 Changed 3 years ago by pingou

  • Cc pingou added

comment:6 Changed 3 years ago by lmacken

  • Owner set to lmacken
  • Milestone set to Fixed, but not yet deployed
  • Status changed from new to assigned

Fixed in git. Will deploy shortly.

comment:7 Changed 3 years ago by lmacken

  • Status changed from assigned to closed
  • Resolution set to fixed

This issue should be resolved with bodhi v0.8.3, which is currently deployed to production.

Note: See TracTickets for help on using tickets.