Ticket #449 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

[PATCH] print query results to stdout instead of stderr

Reported by: till Owned by:
Priority: major Milestone:
Component: bodhi-client Version:
Keywords: patch Cc:
Blocked By: Blocking:

Description

This allows to use the information one is interested in other scripts using a pipe, e.g. to get a list of critpath builds that are not yet approved, one can use:

./client.py 2>/dev/null --critpath --untested --release F13 | cut -d" " -f 2

Attachments

0001-print-query-results-to-stdout-instead-of-stderr.patch (5.6 KB) - added by till 4 years ago.
[PATCH] print query results to stdout instead of stderr

Change History

Changed 4 years ago by till

[PATCH] print query results to stdout instead of stderr

comment:1 Changed 4 years ago by lmacken

  • Status changed from new to closed
  • Resolution set to fixed

Applied in 44f5d5a0ab0e6a638ac0b9722d773f388057a8e8

This also works around the logging issues caused by Yum, among other things.

Thanks again!

Note: See TracTickets for help on using tickets.