Ticket #374 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

bodhi submission page problem with submitting multiple package versions as one update.

Reported by: tgl Owned by:
Priority: major Milestone:
Component: bodhi-server Version:
Keywords: Cc:
Blocked By: Blocking:

Description

I just had severe problems trying to submit fc12 and fc11 updates of postgresql as a single update; I ended up having to submit them as two separate updates. Thinking back, I think that the actual problem may be that you can't *add* a package to an existing update. As best I can remember, I did this:

  • Log in at admin.fedoraproject.org, click New Update.
  • Manually type postgresql-8.4.2-1.fc12 into the package text field.
  • Type carriage return, thinking this would verify the package name.
  • Curse as I realize the webapp took that as a "Submit" click (usability bug here IMO).
  • Click on "revoke submission request", then on "edit".
  • Click "add new package", then fill in postgresql-8.3.8.-1.fc11 and the rest of the fields. All appears well.
  • Submit.
  • Observe that the resulting success page mentions postgresql-8.3.8.-1.fc11 twice and the fc12 update not at all.
  • Re-edit, and find that indeed only the fc11 package is there.
  • Click on "add new package", add postgresql-8.4.2-1.fc12 again.
  • Submit.
  • Observe that now only postgresql-8.4.2-1.fc12 is mentioned (twice). Swear some more.
  • File the .fc11 package as a separate update.
  • Report bug.

Change History

comment:1 Changed 4 years ago by tgl

After digging through the open tickets I realize that this is probably the exact same problem described at https://fedorahosted.org/bodhi/ticket/251 ... which has been ignored for more than a year :-(

comment:2 Changed 4 years ago by lmacken

  • Resolution set to fixed
  • Status changed from new to closed

Fixed (see 251 for details)

Note: See TracTickets for help on using tickets.