Ticket #312 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Update form package build autocompletetion not working well

Reported by: hno Owned by:
Priority: minor Milestone:
Component: bodhi-server Version:
Keywords: Cc:
Blocked By: Blocking:

Description

The package build autocompletion feature in the new update request form is not working well. If just a package name is entered then a long list of all available builds in that package is given in mostly random order it seems. If one tries to enter some parts of the version number as well no builds at all is given.

Some suggestions to improve this:

  • Sort the returned builds in chronological order with newest first.
  • Allow for partial version number entry. I.e. bzr-1.13 should return bzr-1.13.1-1.fc10, bzr-1.13.1-1.fc11, bzr-1.13-1.fc10, bzr-1.13-1.fc11 (all builds starting with 1.13 followed by a non-digit, sorted chronologically with newest first).
  • Don't include rawhide releases (currently f11) in the package autocompletion.
  • Perhaps add a release specification separate from the builds. Less risk of confusion that way, especially when there is multiple packages which have to be released together in one update.

Change History

comment:1 Changed 4 years ago by lmacken

Most of this implemented in 8c90438f7257af7241d4c89d7017361cf7a9ed0b

It still doesn't support the partial version number entry, which would be nice to have.

comment:2 Changed 4 years ago by lmacken

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.