Ticket #380 (closed defect: wontfix)

Opened 3 years ago

Last modified 3 years ago

initscripts: scheduled against wrong distro

Reported by: kparal Owned by:
Priority: critical Milestone: Hot issues
Component: tests Keywords:
Cc: Blocked By:
Blocking:

Description

James discovered a problem where openssh was upgraded to f17 version on a f15 system. There is probably a bug in initscripts's control.autoqa. But because we plan to remove initscripts soon, we just disabled the test for now as a hotfix on production server. If we don't decide to remove initscripts, we need to fix the bug.

<jlaska> nothing urgent ... just an FYI on something I've come across on the autoqa production test clients
<jlaska> last month, a few fc15 test clients were down because an fc17 openssh package was installed on them
<jlaska> (which caused ssh logins to fail)
<jlaska> I fixed the issue, but wasn't able to figure out the cause
<jlaska> the problem surfaced again today
<jlaska> Sep 12 15:11:45 Updated: openssh-5.9p1-4.fc17.x86_64
<jlaska> this is on an fedora-release-15-3.noarch
<jlaska> system
<jlaska> not urgent, I'll correct the problem on affected systems 
<jlaska> but still not sure how they're getting installed
<jlaska> aha!
<jlaska> initscripts
<jlaska> https://fedorahosted.org/pipermail/autoqa-results/20110912/424699.html
<jlaska> and 
<jlaska> https://fedorahosted.org/pipermail/autoqa-results/20110912/424827.html
<jlaska> so initscripts is somehow running on an fc17 systems ... odd .. I thought the control.autoqa prevented that
<jlaska>         distro = get_distro(autoqa_args['nvrs'][0])
* kparal is back
<jlaska> however, the control file only shows autoqa_args['nvr'] (not 'nvrs') ... is that the problem? 
<jlaska> http://autoqa.fedoraproject.org/results/191601-autotest/10.5.124.160/control
<kparal> it is probably really caused by initscripts test
<kparal> we're going to remove it soon
<jlaska> it is ... but only because the test was incorrectly scheduled against fc15 systems (I think)
<kparal> if we don't remove it, I'll look at this issue
<jlaska> I'm going to hotfix this to avoid having to fix this again (prior to initscripts removal)
<kparal> currently I think it would be easier to just disable initscripts execution
<jlaska> I can do that too ... even better! :)
<jlaska> just set execute = False in the control.autoqa?
<kparal> just delete tests/initscripts on the production server
<kparal> or yes, amend control.autoqa
<kparal> both works
<kparal> I'll create a ticket about this
<jlaska> I think I see the bug, but easy for now just to disable
<jlaska> added to initscripts/control.autoqa on production ...
<jlaska> # Fri Sep 16 12:11:20 UTC 2011 - jlaska
<jlaska> # initscripts is incorrectly being scheduled on systems of a different release
<jlaska> # (see https://fedorahosted.org/pipermail/autoqa-results/20110912/424827.html)
<jlaska> execute = False

Change History

comment:1 Changed 3 years ago by kparal

  • Status changed from new to closed
  • Resolution set to wontfix

Initscripts test has been removed in commit a9de8d3. This ticket is no longer valid.

Note: See TracTickets for help on using tickets.