Ticket #200 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

!= operator not working in path expressions?

Reported by: lkrejci Owned by: lutter
Priority: major Milestone: next
Component: Augeas Version: 0.8.0
Keywords: Cc:
Blocked By: Blocking:

Description

This is reproducable on Fedora 14 with augeas 0.8.1:

1) Have a daily cron job in your /etc/crontab: 0 0 * * * root echo hello 1 0 * * * root echo hi

2) augtool> match /files/etc/crontab/entry[time/minute = '0'] /files/etc/crontab/entry[1] = echo hello augtool> match /files/etc/crontab/entry[time/minute = '1'] /files/etc/crontab/entry[2] = echo hi augtool> match /files/etc/crontab/entry[time/minute != '1']

(no matches)

augtool> match /files/etc/crontab/entry[time/minute != '0']

(no matches)

Change History

comment:1 in reply to: ↑ description Changed 3 years ago by lkrejci

Oh, forgot to format that:

1) Have a daily cron job in your /etc/crontab:

0 0 * * * root echo hello 
1 0 * * * root echo hi

2)

augtool> match /files/etc/crontab/entry[time/minute = '0'] 
/files/etc/crontab/entry[1] = echo hello 
augtool> match /files/etc/crontab/entry[time/minute = '1'] 
/files/etc/crontab/entry[2] = echo hi 
augtool> match /files/etc/crontab/entry[time/minute != '1']
    (no matches)
augtool> match /files/etc/crontab/entry[time/minute != '0']
    (no matches)

comment:2 Changed 3 years ago by lkrejci

  • Resolution set to invalid
  • Status changed from new to closed

This seems to be Fedora specific: https://bugzilla.redhat.com/show_bug.cgi?id=710034

Note: See TracTickets for help on using tickets.